Opened 6 years ago

Closed 5 years ago

#12231 closed defect (worksforme)

SSL-Observatory exception 0x80004005

Reported by: bastik Owned by: zyan
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Sometimes I get this error in the console:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.host]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Users/[redacted

username]/AppData/Roaming/Mozilla/Firefox/Profiles/[redacted profile]/extensions/https-everywhere@eff.org/components/ssl-observatory.js :: SSLObservatory.prototype.submitCertChainForChannel :: line 434"

data: no]

The line in question contains:

this.log(INFO, "SHA-256 hash of cert chain for "+new String(channel.URI.host)+" is "+ chain_hash);

Add-on Version: 3.5.1
Firefox Version: 29.0.1 (German)
OS: Win 7 SP1 (64bit German)

I'm unable to reproduce it. I just found them because #12224 got created and I experience crashes as well. Not as frequent as the reporter mentions.

Child Tickets

Attachments (1)

source-code changed.png (23.9 KB) - added by bastik 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by bastik

I just got this message while (re-)loading trac.tpo and I still don't know how to trigger it.

comment:2 Changed 6 years ago by zyan

https://groups.google.com/forum/#!msg/mozilla.dev.platform/FYmXl6a5OOM/RoEvfIYJjEgJ suggests that this error comes from hitting URLs for which 'host' is not defined, ex: 'about:' URLs. Maybe we should only be running submitCertChain on scheme == "https" URLs anyway, so it would be an easy thing to filter out.

comment:3 Changed 6 years ago by zyan

Maybe this fixes it? https://github.com/diracdeltas/https-everywhere/commit/acdae544ebddf0b6cf39927073e9a1854a281f44

But probably low priority unless the exception is actually preventing SSL obs. from working correctly.

comment:4 in reply to:  3 Changed 6 years ago by bastik

Replying to zyan:

Maybe this fixes it? https://github.com/diracdeltas/https-everywhere/commit/acdae544ebddf0b6cf39927073e9a1854a281f44

I copied the lines, closed FF and added the lines to my local addon, then I restarted the browser and used it with the console open. This did not change anything.

But probably low priority unless the exception is actually preventing SSL obs. from working correctly.

Alright, I don't mind.

Changed 6 years ago by bastik

Attachment: source-code changed.png added

comment:5 Changed 5 years ago by jsha

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.