Opened 5 years ago

Closed 16 months ago

#12246 closed task (wontfix)

Make Integration Tests Run

Reported by: earthrise Owned by: earthrise
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Travis, the integration tests aren't running, because there is no local ooni backend. Therefore I'm not sure if the integration tests are ever run automatically. I've started a Vagrantfile to make running these tests (with a local ooni backend) easy and reproducible:

https://github.com/LeastAuthority/ooni-releng/blob/master/Vagrantfile

There are still test errors when it runs, because the ooni backend is missing decks and nettests that the integration tests expect it to have.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by earthrise

Owner: changed from hellais to earthrise
Status: newassigned

comment:2 Changed 23 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:3 Changed 16 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: assignedclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.