Opened 5 years ago

Closed 12 months ago

#12397 closed defect (worksforme)

Tor Browser should proactively identify missing dependencies and suggest resolution

Reported by: anon Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Normal Keywords: win32, needs-triage
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

See ticket #10789 for examples of where odd failures due to missing symbol dependencies occur and cause user confusion. If Tor Launcher identified missing dependencies and suggested resolution much end user support confusion and overhead would be reduced.

NOTE: this is specific to Win32/Win64 environments. The same may be applicable in *nix environments but so far has not been problematic to the degree that Windows environments have been.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by mcs

Cc: mcs added
Component: Tor LauncherTor bundles/installation
Owner: changed from brade to erinn

The "Couldn't load xpcom" message is generated by Firefox, so that message would need to be improved by patching Firefox. Tor Launcher cannot inform the user because Tor Launcher is implemented as a Firefox extension... and in these situations Firefox is not able to fully start up, which means Tor Launcher won't be started.

I am not sure how common it is for users to encounter missing symbols / missing DLLs, but improving the error alert displayed by Firefox to suggest checking anti-virus software, etc. might be worthwhile. I think the problem is usually called by a corrupt/damaged installation of the browser or by AV blocking.

comment:2 Changed 5 years ago by mcs

Cc: brade added

comment:3 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:4 Changed 23 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:5 Changed 12 months ago by gk

Resolution: worksforme
Status: newclosed

We essentially only had issues with AV/Firewall software in this regard and lately not so much. Closing as WORKSFORME.

Note: See TracTickets for help on using tickets.