Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12417 closed defect (not a bug)

Code signing issue.

Reported by: codesigning Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A couple versions back, Tor stopped launching on both of my Macs. Others have reported this issue, but it doesn't look like anyone has provided the information you need to fix this.

Here's the "codesign" output for Tor 3.6.2, downloaded today from torproject.org.

codesign --verify -v /Volumes/Tor\ Browser/TorBrowser.app:
/Volumes/Tor Browser/TorBrowser.app: invalid Info.plist (plist or signature have been modified)

codesign -dv /Volumes/Tor\ Browser/TorBrowser.app:
Identifier=org.torproject.TorBrowserBundle
Format=bundle with generic
CodeDirectory v=20100 size=160 flags=0x2(adhoc) hashes=1+3 location=system
Signature=adhoc
Info.plist=not bound
TeamIdentifier=not set
Sealed Resources version=1 rules=4 files=1
Internal requirements count=1 size=60

For comparison, the same commands run on Firefox 30...

codesign --verify -v /Applications/Firefox.app:
/Applications/Firefox.app: valid on disk
/Applications/Firefox.app: satisfies its Designated Requirement

codesign -dv /Applications/Firefox.app:
Executable=/Applications/Firefox.app/Contents/MacOS/firefox
Identifier=org.mozilla.firefox
Format=bundle with Mach-O universal (i386 x86_64)
CodeDirectory v=20100 size=228 flags=0x0(none) hashes=5+3 location=embedded
Signature size=4232
Signed Time=Jun 5, 2014, 7:29:18 PM
Info.plist entries=20
TeamIdentifier=not set
Sealed Resources version=1 rules=13 files=105
Internal requirements count=2 size=356

I see this under both Mac OS X 10.7.5 & Mac OS X 10.9.3.

Thanks!

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by codesigning

Tried the same commands with Tor 3.5.1.

codesign --verify -v /Applications/Tor.app:
/Applications/Tor.app: valid on disk
/Applications/Tor.app: satisfies its Designated Requirement

codesign -dv /Applications/Tor.app:
Executable=/Applications/Tor.app/Contents/MacOS/TorBrowserBundle
Identifier=org.torproject.TorBrowserBundle
Format=bundle with generic
CodeDirectory v=20100 size=160 flags=0x2(adhoc) hashes=1+3 location=system
Signature=adhoc
Info.plist entries=19
TeamIdentifier=not set
Sealed Resources version=1 rules=4 files=1
Internal requirements count=1 size=60

comment:2 Changed 5 years ago by codesigning

Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:3 Changed 5 years ago by codesigning

Resolution: not a bug
Status: newclosed

comment:4 Changed 5 years ago by codesigning

This appears to be an OS X issue, possibly triggered by the Tor bundle's static creation & modification dates.

Old information was being cached as described here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=398450

Note: See TracTickets for help on using tickets.