Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12473 closed defect (not a bug)

ARM does not display correct fingerprint after change

Reported by: rdewald Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version: Tor: 0.2.4.22
Severity: Keywords: fingerprint
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I originally set-up my relay incorrectly as an exit and I didn't realize this until I got the e-mail from tor-weather that it was stable (I am on a home cable Internet connection). I moved that torrc and created a new one using the ARM wizard.

The finger print for my new relay is 0EFDE7593A6B070D816B23FB628EE441788A6870

the attached screen-shot displays what ARM shows

Child Tickets

Attachments (1)

tor-bug-rpt1.png (90.6 KB) - added by rdewald 5 years ago.
the fingerprint displayed is for my old relay configuration, not currently running

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by rdewald

Attachment: tor-bug-rpt1.png added

the fingerprint displayed is for my old relay configuration, not currently running

comment:1 Changed 5 years ago by atagar

Resolution: not a bug
Status: newclosed

Hi rdewald, thanks for running a relay! The fingerprint arm is showing in its header panel is correct...

https://atlas.torproject.org/#details/CA4B2AFAEC7564A835C8CECB908109D3AB40999F

Personally I'd suggest avoiding the arm wizard. It was a neat idea, but never got much usage (you're only the third person that has told me that used it - ever) so I'm removing it in the next release. Its lack of usage would make me a little wary of its reliability.

comment:2 Changed 5 years ago by rdewald

Ok, then is the fact that

sudo cat /var/lib/tor/fingerprint

gives me

rdewald 0EFDE7593A6B070D816B23FB628EE441788A6870

a problem?

Note: See TracTickets for help on using tickets.