Opened 5 years ago

Closed 5 years ago

#12482 closed defect (not a bug)

Google Maps and BBC Iplayer seeing non-Exit node country

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Though I'm not very tech savvy I have been using Tor for years and it used to work where location-aware sites like Google Maps and BBC would only see the exit node's location, but that's not the case anymore. I don't know if Google Maps is just showing me the US as a defualt location or if it's seeing through one or more hops on the tor circuit and the BBC is sure I'm not in Britain (which, at the moment, is correct but I didn't used to have any problem keeping up with my soaps while traveling). I don't know enough about how this all is supposed to work so I can't really give anymore information beyond that this is for the 3.6.2 and I tried it with and without flash since I know flash is bad, same result. If these sites are seeing past the exit node, that seems like a big problem to me.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by cypherpunks

Summary: Google Maps and BBC Iplayer seeing actual countryGoogle Maps and BBC Iplayer seeing non-Exit node country

comment:2 Changed 5 years ago by cypherpunks

Just tested google maps, got:

United States
Not your current location? Correct it

Exit node wasn't {us}, and google was wrong about actual country.
Looks like it's default country if google nothing knows about actual geo of user. (many geo db reports anonymous proxy country with code A1 for ip adresses of tor relays).

comment:3 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.