Opened 5 years ago

Closed 5 years ago

#12490 closed defect (fixed)

Tripadvisor more/less onclick item fails for reviews

Reported by: mkidd Owned by: zyan
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.4.3
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For HTTP-E 3.5.3 and 3.5.1 (neither seems to be an option in the Version pulldown?!), the more/less links for TripAdvisor reviews fail. For example, go here:

http://www.tripadvisor.com/Hotel_Review-g56935-d99710-Reviews-Stone_Lizard_Lodging-Blanding_Utah.html

Find a review that is too long for the initial view. Clicking on the more link at the bottom of the review fails.

The HTML for these links looks something like:

<span class="taLnk hvrIE6 tr210874369 moreLink ulBlueLinks" onclick="ta.util.cookie.setPIDCookie(2247);ta.call('ta.servlet.Reviews.expandReviews',event,this,'review_210874369', '1', 2247)">

The link, or more precisely the onclick code, fails because the TA variable is not defined when HTTPS-E is enabled. Presumably TA stands for TripAdvisor and HTTPS-E is blocking whatever code defines this variable.

My guess is that ticket #12063 https://trac.torproject.org/projects/tor/ticket/12063#no1 is related with the same root cause.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by bm

Resolution: fixed
Status: newclosed

Fixed in 3eef4297.

Note: See TracTickets for help on using tickets.