Opened 5 years ago

Closed 5 years ago

#12525 closed defect (duplicate)

TBB bug report you requested

Reported by: eli Owned by: erinn
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.20
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello - I'm forwarding the following Tor log record as requested. I don't know why the error report was repeated three times, but I submit all, as well as the startup items in case the time stamps are helpful.


[Wed Jul 2 17:30:42 2014] The Tor Software is Running - You are currently running version "0.2.4.20 (git-3cb5c70beec5bf46)" of the Tor software.

[Wed Jul 2 17:31:01 2014] Connected to the Tor Network - We were able to successfully establish a connection to the Tor network. You can now configure your applications to use the Internet anonymously.

[Wed Jul 2 18:00:44 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_free_(): Bug: microdesc_free() called from src/or/microdesc.c:377, but md was still referenced 1 node(s); held_by_nodes == 1
"
[Wed Jul 2 18:00:44 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_free_(): Bug: microdesc_free() called from src/or/microdesc.c:377, but md was still referenced 1 node(s); held_by_nodes == 1
"
[Wed Jul 2 18:00:44 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_free_(): Bug: microdesc_free() called from src/or/microdesc.c:377, but md was still referenced 1 node(s); held_by_nodes == 1
"


The following may also be of some use:
Running on win7 64 bit.
I run this Tor instance to support a torbirdyed Thunderbird mail client. I don't usually run Vidalia on this box, but will do so if you want me to collect logs. If so, please let me know what log levels you wish to see. The above is the first time I've seen this error in the month or so since running torbrowser 3.6.2. I've no idea of how long we'll have to wait for the bug to show up again.

I also run torbrowser 3.6.2 on a separate, dedicated machine on my LAN to support a bridge relay. That instance of the browser is also showing problems. I don't see any way that those problems could be related to the present bug, but I'll send you the details of that installation if you wish.

HTH - eliaz
gpg 0x04DEF82B

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by erinn

Component: Tor bundles/installationTor

comment:2 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

Closing as duplicate of #7164 . Thanks for reporting!

Note: See TracTickets for help on using tickets.