Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#12558 closed defect (duplicate)

Tor doesn't show warning for non-reachable IPv6 OR port

Reported by: anong Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.22
Severity: Normal Keywords: ipv6 tor-relay 026-triaged-1 lorax
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I recently upgraded my routers firmware. After that, I restarted Tor as usual. After one day, I noticed that atlas is showing my relay as offline since restart.

After more than hour of investigating, I found out that my router gave my Raspberry Pi a new IPv6 interface ID. Due to this, my port forwarding didn't work anymore.

The strange thing is: In my tor logs, I saw this:

"Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor."

Looks like Tor was just referring to my IPv4 OR Port, which was still reachable, and didn't notice my non-reachable IPv6 OR Port. This issue should be fixed.

Child Tickets

Change History (7)

comment:1 Changed 5 years ago by anong

Keywords: tor-relay added

comment:2 Changed 5 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: 0.2.6.x-final

comment:3 Changed 5 years ago by nickm

Keywords: 026-triaged-1 added

At the very least we could improve the message here.

Last edited 5 years ago by nickm (previous) (diff)

comment:4 Changed 5 years ago by teor

Keywords: lorax added
Milestone: Tor: 0.2.6.x-finalTor: 0.2.???

This actually requires testing the reachability of each port, not just the first IPv4 port.

comment:5 Changed 4 years ago by teor

Resolution: duplicate
Severity: Normal
Status: newclosed

This is a duplicate of #6939.

comment:6 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:7 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.