Opened 5 years ago

Closed 5 years ago

#12596 closed defect (not a bug)

Get error (Bad Request) after few minutes running tor relay

Reported by: TorToGo Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Keywords: Bad Request
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

after starting tor-server on my raspberry every think seems to be ok. Self-testing indicates your ORPort is reachable from the outside,...
after few minutes running i get this warnings:

Jul 11 12:14:49.000 [warn] Received http status code 400 ("Bad Request") from server '212.112.245.170:80' while fetching "/tor/server/d/005D2F74001082EBA3439E64662D099CD377F896+008130FE30D166C279F549B80DB91C52A7579AD8+00B1F0B7BC9E0F9B17FD674493AAAC8845B0EBF6+00C8....8F3DFF39835.z". I'll try again soon.

top shows me that tor is running, but from outside tor seems to be frozen, there is no more tor-traffic.

i'm wondering that the request uses port 80, ...is there a mistake in my configuration?

SocksPort 0
ORPort 9001
DirPort 9030
ExitPolica reject *:*

may be someone can help me

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by nickm

Component: - Select a componentTor
Milestone: Tor: unspecified
Resolution: not a bug
Status: newclosed

Hm, that message probably shouldn't be a warning; Though is it possible that you have some upstream web filter running?

"ExitPolica" should be "ExitPolicy", but I don't think that you have that typo in your torrc, or else Tor wouldn't start.

In any case, I don't see a Tor bug here. This website is just a bug tracker, and it's not really a support forum. You will probably be able to get better help on the tor-relays mailing list, or from the help@… address.

Note: See TracTickets for help on using tickets.