Opened 5 years ago

Closed 5 years ago

#12597 closed task (duplicate)

Make all relays directory servers

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-guard tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

During the entry guard discussions, we have decided that it's a good idea to make all relays directory servers. We mainly needed the entry guards to be directories, but it seems easier and more elegant to just turn all relays to directory servers.

This is easier nowadays than in the past because BEGIN_DIR makes it so that directory servers don't need to have a separate DirPort open. (However, maybe relays get the V2Dir flag only if they have a DirPort open?)

Also, since all relays have all the directory documents anyway, it doesn't further bloat their disk to become directory servers.

Putting this in 0.2.6, but probably deferrable.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by sysrqb

Resolution: duplicate
Status: newclosed

Closing as dupe of #12538

Note: See TracTickets for help on using tickets.