Opened 5 years ago

Closed 5 years ago

#12608 closed defect (duplicate)

alpha windows build fails with "newly created file is older than distributed files!"

Reported by: dcf Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-4.0
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With 6ce9149b, three times in a row, I've gotten an error like this in "build-alpha":

+ export PATH=/home/ubuntu/install/mingw-w64/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
+ PATH=/home/ubuntu/install/mingw-w64/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
+ cd /home/ubuntu/build
+ mkdir -p mingw-w64/mingw-w64-headers32
+ cd mingw-w64/mingw-w64-headers32
+ ../../mingw-w64-git/mingw-w64-headers/configure --host=i686-w64-mingw32 --prefix=/home/ubuntu/install/mingw-w64/i686-w64-mingw32 --enable-sdk=all --enable-secure-api --enable-idl
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock

Once, it was in a different place, still in utils for windows:

+ make -j2
make: Warning: File `../../mingw-w64-git/mingw-w64-tools/widl/Makefile.in' has modification time 0.015 s in the future
/bin/bash ./config.status --recheck
running CONFIG_SHELL=/bin/bash /bin/bash ../../mingw-w64-git/mingw-w64-tools/widl/configure --prefix=/home/ubuntu/install/mingw-w64 --target=i686-w64-mingw32 target_alias=i686-w64-mingw32 --no-create --no-recursion
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-w64-mingw32
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: newly created file is older than distributed files!
Check your system clock
make: *** [config.status] Error 1

The console output is:

HEAD is now at dc61e62... Disable git fetching during build.

****** Starting Utilities Component of Windows Bundle (1/5 for Windows) ******

--- Building utils-windows for precise i386 ---
Stopping target if it is up
Killing target since it did not shutdown within 10 seconds
Making a new image copy
Formatting 'target-precise-i386.qcow2', fmt=qcow2 size=11811160064 backing_file='base-precise-i386.qcow2' encryption=off cluster_size=65536
Starting target
Checking if target is up.
Preparing build environment
Updating apt-get repository (log in var/install.log)
Installing additional packages (log in var/install.log)
Grabbing package manifest
Creating build script (var/build-script)
Running build script (log in var/build.log)
./bin/gbuild:21:in `system!': failed to run on-target setarch i386 bash -x < var/build-script > var/build.log 2>&1 (RuntimeError)
        from ./bin/gbuild:122:in `build_one_configuration'
        from ./bin/gbuild:224
        from ./bin/gbuild:219:in `each'
        from ./bin/gbuild:219
        from ./bin/gbuild:217:in `each'
        from ./bin/gbuild:217
make: *** [build-alpha] Error 1

The linux build didn't have the problem.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by dcf

git bisect says:

ad43e17f6fdec22be8c971483d5123c172b76c61 is the first bad commit
commit ad43e17f6fdec22be8c971483d5123c172b76c61
Author: Kathy Brade <brade@pearlcrescent.com>
Date:   Thu Jun 19 15:10:12 2014 -0400

    Bug 12406: use MinGW-w64 v3.1.0 for TBB 4.x
    
    This also requires newer versions of gcc and binutils.
    We now fetch MinGW-w64 using git instead of svn.

ad43e17f6fdec22be8c971483d5123c172b76c61

comment:2 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Yes, I saw this, too, while working on #12391. As this is not happening always either let's mark this one as a duplicate of #12391. (Apart from that a fix for the former is probably fixing this one as well)

Note: See TracTickets for help on using tickets.