Opened 5 years ago

Closed 5 years ago

#12624 closed defect (fixed)

tbb-nightly-2014-07-13 chokes with "Bad password or authentication cookie on controller."

Reported by: asn Owned by: isis
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: MikePerry201407R
Cc: mcs, brade, isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm trying to use tbb-nightly-2014-07-13/tor-browser-linux64-tbb-nightly_en-US.tar.xz but I'm getting the following when I start it up:

$ ./tor-browser_en-US/start-tor-browser 
Launching Tor Browser for Linux in /home/test/tor-browser_en-US/Browser...

(process:11604): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Jul 14 14:18:55.540 [notice] Tor v0.2.6.0-alpha-dev (git-d3b80c6a61912bce) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.1h and Zlib 1.2.8.
Jul 14 14:18:55.540 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jul 14 14:18:55.540 [notice] This version is not a stable Tor release. Expect more bugs than usual.
Jul 14 14:18:55.541 [notice] Read configuration file "/home/test/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc-defaults".
Jul 14 14:18:55.541 [notice] Read configuration file "/home/test/tor-browser_en-US/Browser/TorBrowser/Data/Tor/torrc".
Jul 14 14:18:55.544 [notice] Opening Control listener on 127.0.0.1:9151
Jul 14 14:18:55.544 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Jul 14 14:18:55.000 [notice] Pluggable transport proxy (fte exec ./TorBrowser/Tor/PluggableTransports/fteproxy.bin --managed) does not provide any needed transports and will not be launched.
Jul 14 14:18:55.000 [notice] Pluggable transport proxy (obfs2,obfs3,scramblesuit exec ./TorBrowser/Tor/PluggableTransports/obfsproxy.bin managed) does not provide any needed transports and will not be launched.
Jul 14 14:18:55.000 [notice] Pluggable transport proxy (flashproxy exec ./TorBrowser/Tor/PluggableTransports/flashproxy-client --register :0 :9000) does not provide any needed transports and will not be launched.
Jul 14 14:18:55.000 [notice] Pluggable transport proxy (meek exec ./TorBrowser/Tor/PluggableTransports/meek-client-torbrowser -- ./TorBrowser/Tor/PluggableTransports/meek-client --url=https://meek-reflect.appspot.com/ --front=www.google.com) does not provide any needed transports and will not be launched.
Jul 14 14:18:55.000 [notice] Parsing GEOIP IPv4 file /home/test/tor-browser_en-US/Browser/TorBrowser/Data/Tor/geoip.
Jul 14 14:18:55.000 [notice] Parsing GEOIP IPv6 file /home/test/tor-browser_en-US/Browser/TorBrowser/Data/Tor/geoip6.
Jul 14 14:18:55.000 [notice] Bootstrapped 0%: Starting
Jul 14 14:18:55.000 [notice] New control connection opened from 127.0.0.1.
Jul 14 14:18:55.000 [warn] Bad password or authentication cookie on controller.
Jul 14 14:18:55.000 [notice] New control connection opened from 127.0.0.1.
Jul 14 14:18:55.000 [warn] Bad password or authentication cookie on controller.
Jul 14 14:18:55.000 [notice] New control connection opened from 127.0.0.1.
Jul 14 14:18:55.000 [warn] Bad password or authentication cookie on controller.
Jul 14 14:18:56.000 [notice] New control connection opened from 127.0.0.1.
Jul 14 14:18:56.000 [warn] Bad password or authentication cookie on controller.
...

and it keeps on going. In the meanwhile, I can interact with tor launcher. When I try to save my settings and start up Tor, I get Unable to save Tor settings.

Child Tickets

Change History (7)

comment:1 Changed 5 years ago by gk

Cc: mcs brade added

Might be in fact a TorLancher issue, CCing Mark and Kathy...

comment:2 Changed 5 years ago by mcs

Owner: changed from erinn to isis
Status: newassigned

This problem was introduced by https://gitweb.torproject.org/builders/tor-browser-bundle.git/commit/a566e85f785c12157283920a179cdc64fdd28b32

TOR_CONTROL_PASSWD is always set to "secret" at the time Tor Browser is started.

Reassigning to isis.

comment:3 Changed 5 years ago by isis

My patch sets TOR_CONTROL_PASSWD='secret', and then in the setControlPortPasswd() function it specifically ignores the password if it is set to 'secret':

    test -z "$ctrlPasswd" -o "$ctrlPasswd" = $'\"secret\"' && return

But I'll check one of the nightlies tonight.

comment:4 in reply to:  3 Changed 5 years ago by mcs

Replying to isis:

My patch sets TOR_CONTROL_PASSWD='secret', and then in the setControlPortPasswd() function it specifically ignores the password if it is set to 'secret':

    test -z "$ctrlPasswd" -o "$ctrlPasswd" = $'\"secret\"' && return

But I'll check one of the nightlies tonight.

Thanks. I think the problem is that, even though the export TOR_CONTROL_PASSWD line inside setControlPortPasswd() is skipped, the "secret" value is still passed to Tor Browser (and thus to Tor Launcher) because of this:

TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" ...

comment:5 Changed 5 years ago by isis

I can't test this until my local build finishes, because the last nightly doesn't have a good GPG signature on the sha256sums.txt file, and also the SHA256 doesn't match, so I'm not running it. I suppose I can try the one from two days ago.

comment:6 Changed 5 years ago by isis

Cc: isis added
Keywords: MikePerry201407R added
Status: assignedneeds_review

All right, it is messed up, and mcs is right that my patch did it. Looking back on the .orig files from my rebasing, it looks like I missed a couple lines. Oops, sorry about that.

The fix is to unset TOR_CONTROL_PASSWD before the return from setControlPasswd() in RelativeLink/RelativeLink.sh. It's one tiny commit, in my bug12624-controlpasswd-unset branch.

comment:7 Changed 5 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Fixed in commit 798f147f44ff80d2104ed3b0162f17198dd2a4f2, thanks.

Note: See TracTickets for help on using tickets.