Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12629 closed defect (not a bug)

Tor Browser crashes on startup

Reported by: Atalanttore Owned by:
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

starting the Tor Browser on my Kubuntu 14.04 x64 machine always results in an error message "Tor unexpectedly exited."

Terminal output:

Launching Tor Browser Bundle for Linux in /usr/bin/tor-browser

(process:6808): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:6808): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:6808): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:6808): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:6808): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
Jul 14 21:05:40.745 [notice] Tor v0.2.4.21 (git-f5def645adfb32be) running on Linux with Libevent 2.0.21-stable and OpenSSL 1.0.1g.
Jul 14 21:05:40.745 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jul 14 21:05:40.745 [notice] Read configuration file "/usr/bin/tor-browser/Data/Tor/torrc-defaults".
Jul 14 21:05:40.745 [notice] Read configuration file "/usr/bin/tor-browser/Data/Tor/torrc".
Jul 14 21:05:40.748 [notice] Opening Control listener on 127.0.0.1:9151
Jul 14 21:05:40.748 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
Jul 14 21:05:40.749 [warn] /usr/bin/tor-browser/Data/Tor is not owned by this user (ata, 1000) but by root (0). Perhaps you are running Tor as the wrong user?
Jul 14 21:05:40.749 [warn] Failed to parse/validate config: Couldn't access/create private data directory "/usr/bin/tor-browser/Data/Tor"
Jul 14 21:05:40.749 [err] Reading config failed--see warnings above.

(firefox:6808): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed

(firefox:6808): Gtk-CRITICAL **: IA__gtk_clipboard_get_for_display: assertion '!display->closed' failed

(firefox:6808): Gtk-CRITICAL **: IA__gtk_clipboard_get_for_display: assertion '!display->closed' failed

Tor Browser exited cleanly.

Regards,
Atalanttore

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by cypherpunks

You unpacked bundle to /usr/bin/tor-browser as root and tries to run it as ata (id 1000) user. Find better place where ata could write and run stuff then unpack Tor Browser by ata there.

Last edited 5 years ago by cypherpunks (previous) (diff)

comment:2 Changed 5 years ago by gk

Component: - Select a componentTor bundles/installation
Keywords: crash startup removed
Resolution: not a bug
Status: newclosed
Version: Tor: 0.2.4.21

Generally, unpacking as a normal user and starting the bundle as a normal user is the recommended way. Anyway, this is not a bug.

comment:3 Changed 5 years ago by Atalanttore

I have installed the tor browser bundle from repository.

sudo apt-get install tor-browser

The unpacking was done by the package manager.

Regards,
Atalanttore

comment:4 Changed 5 years ago by cypherpunks

I have installed the tor browser bundle from repository.

PPA? Which one?

Found one, they not showing any path to start with, assuming ubuntu magic. Package showing direct path to magic start-script: /usr/bin/tor-browser-en.sh

Tor v0.2.4.21

Outdated, was packed prior 3.6.2 bundle.

comment:5 in reply to:  4 Changed 5 years ago by Atalanttore

Replying to cypherpunks:

I have installed the tor browser bundle from repository.

PPA? Which one?

This PPA:
https://launchpad.net/~upubuntu-com/+archive/ubuntu/tor64?field.series_filter=trusty

Found one, they not showing any path to start with, assuming ubuntu magic. Package showing direct path to magic start-script: /usr/bin/tor-browser-en.sh

Tor v0.2.4.21

Outdated, was packed prior 3.6.2 bundle.

No start-script, I just enter "tor" in the console.

Regards,
Atalanttore

comment:6 Changed 5 years ago by quuxman

I have the exact same issue, and I'm completely baffled. I also installed from ppa (using trusty):

sudo add-apt-repository ppa:upubuntu-com/tor64
sudo apt-get update
sudo apt-get install tor-browser

And running tor produces exactly the same warnings. I'm totally baffled.

Note: See TracTickets for help on using tickets.