Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12639 closed enhancement (duplicate)

Add QR codes for bridges.tpo

Reported by: n8fr8 Owned by: isis
Priority: Low Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: bridgedb-0.2.3, bridgedb-ui
Cc: isis, n8fr8 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Orbot now supports URI links and/or QR codes for provisioning of bridges.

It would be great if the bridges.torproject.org site could offer one or both of these options.

Bridge lines like this:

obfs3 193.235.207.7:31573 023d7bbc5e8ce179e757acaef17cdcabcb84eac5

need to be URL encoded, and pre-pended with a bridge:// scheme string

bridge://obfs3%20193.235.207.7%3A31573%20023d7bbc5e8ce179e757acaef17cdcabcb84eac5

This URI can then be encoded as a QR using the qrencode command line http://fukuchi.org/works/qrencode/ or other tool

Many thanks for your consideration!

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by isis

Status: newneeds_information

Great! This is good news. Hopefully, it's much easier for people to enter bridges now.

I have a couple concerns:

  1. I tried this on an android device with the latest Orbot (using the qrencode tool you suggested to encode the line above) and Orbot didn't pick up on the URL schema.
  1. No other application (TorLauncher/Tails/that iOS thing) supports that URL-encoded string, so I'm worried that it would be extra confusing buttons in BridgeDB, i.e. ("give me bridges > give me a qrcode > give me a qrcode specifically for Orbot").

comment:2 Changed 5 years ago by isis

Cc: isis n8fr8 added
Keywords: bridgedb-0.2.3 bridgedb-ui added
Priority: normalminor
Resolution: duplicate
Status: needs_informationclosed
Type: defectenhancement

Closing as a duplicate of #11345 and referencing this from there for archival purposes.

comment:3 Changed 4 years ago by eighthave

One thing to keep in mind when encoding things as URIs for QR codes is the special QR code char set that makes for smaller QR Codes for the same URI. The URI needs to only use uppercase letters, numbers, and a few special chars. The char set is

0–9 A–Z space $ % * + - . / : https://en.wikipedia.org/wiki/QR_code#Storage

For Android, that means that the app also has to claim <data android:scheme="BRIDGE" /> so that the URI will be properly directed when scanned from any QR scanner.

Note: See TracTickets for help on using tickets.