Opened 5 years ago

Closed 15 months ago

#12641 closed defect (wontfix)

IStreamClientEndpointStringParser is Deprecated

Reported by: earthrise Owned by: hellais
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I started Ooni on mlab1 and got the message:

/home/mlab_ooni/lib/python2.6/site-packages/Twisted-14.0.0-py2.6-linux-i686.egg/twisted/internet/endpoints.py:30: DeprecationWarning: twisted.internet.interfaces.IStreamClientEndpointStringParser was deprecated in Twisted 14.0.0: This interface has been superseded by IStreamClientEndpointStringParserWithReactor.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by nathan-at-least

Note, this issue does not crop up when the official installation procedure is followed which respects the URLs in requirements.txt. (See https://github.com/m-lab-tools/ooni-support/pull/43 for why we uncovered this issue.) Therefore this is a "future issue" for upgrades. A safe short term solution might be to constrain the twisted version in requirements.txt so that even when md5 checks fail due to errors like the link above, a non-MiTM install will still use the correct twisted version.

comment:2 Changed 5 years ago by hellais

This seems like an mlab specific issue since when I run the following command on an mlab slice:

./bin/python -c 'from twisted.internet import endpoints'

I get:

/home/mlab_ooni/lib/python2.6/site-packages/Twisted-14.0.0-py2.6-linux-i686.egg/twisted/internet/endpoints.py:30: DeprecationWarning: twisted.internet.interfaces.IStreamClientEndpointStringParser was deprecated in Twisted 14.0.0: This interface has been superseded by IStreamClientEndpointStringParserWithReactor.
from twisted.internet.interfaces import (

comment:3 in reply to:  2 Changed 5 years ago by nathan-at-least

Replying to hellais:

This seems like an mlab specific issue since ...

This is an issue with recent releases of twisted. Because the ooni-backend dependencies.txt specifies:

Twisted>=12.2.0
#https://pypi.python.org/packages/source/T/Twisted/Twisted-13.0.0.tar.bz2#md5=68afff4e1efd3757d934e39f70c99f57#egg=Twisted

-then if the official dependency install procedure is followed the issue in this ticket will not be triggered. This is in the category of "not currently a bug, but it may be when we upgrade dependencies, or if users incorrectly install ooni-backend". Is there a way we can mark this ticket to mean that?

Last edited 5 years ago by nathan-at-least (previous) (diff)

comment:4 Changed 5 years ago by cypherpunks

Python 2.7.8 (default, Oct  7 2014, 20:15:29) 
[GCC 4.9.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import twisted
>>> twisted.__version__
'14.0.2'
>>> from twisted.internet import endpoints
>>> 

Is this still an issue on mlab?

comment:5 Changed 22 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:6 Changed 15 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.