Opened 5 years ago

Closed 3 years ago

#12668 closed defect (wontfix)

make test fails with bufferevents enable

Reported by: gsathya Owned by:
Priority: Low Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-tests bufferevents
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

extorport/write_command: [forking] [Lost connection!] 
  [write_command FAILED]
..
extorport/handshake: [forking] [Lost connection!] 
  [handshake FAILED]
..
oom/streambuf: [forking] [Lost connection!] 
  [streambuf FAILED]

Built with --enable-bufferevents on OSX 10.9. Attached complete output of make test.

Child Tickets

Attachments (1)

test.output (6.9 KB) - added by gsathya 5 years ago.
output of make test

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by gsathya

Attachment: test.output added

output of make test

comment:1 Changed 5 years ago by nickm

Keywords: tor-tests added
Milestone: Tor: 0.2.5.x-final
Priority: normalminor

Is this a duplicate of #11578 ? Did your #11578 fix resolve this issue?

I'd take a patch for this if there's a simple one to be had, but keep in mind that the bufferevent code in Tor doesn't work very well, and even fixing this bug won't actually make it a good idea to run Tor with bufferevents enabled.

comment:2 in reply to:  1 Changed 5 years ago by gsathya

Replying to nickm:

Is this a duplicate of #11578 ?

No, #11578 was about fixing the build warnings.

Did your #11578 fix resolve this issue?

Nope.

comment:3 Changed 5 years ago by nickm

Keywords: bufferevents added
Milestone: Tor: 0.2.5.x-finalTor: 0.2.???

Okay; deferring to whenever-somebody-makes-bufferevents-work

comment:4 Changed 3 years ago by nickm

Milestone: Tor: 0.2.???Tor: 0.2.9.x-final
Resolution: wontfix
Status: newclosed

The bufferevents code and corresponding build options have been removed in 0.2.9.2-alpha

Note: See TracTickets for help on using tickets.