Opened 5 years ago

Closed 5 years ago

#12675 closed defect (not a bug)

'Use custom bridges' radio button is not automatically selected when custom bridges are entered

Reported by: harmony Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords:
Cc: asn, phoul, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The fourth screen of the Tor Browser's 'Configure' wizard gives the user the option of either using a standard set of bridges, or entering a set they have obtained elsewhere. These options are presented as radio buttons, and by default the 'Use provided bridges' button is selected.

If the user clicks on the box to enter custom bridges, the associated radio button is not automatically selected; if the user does not spot this or is not aware that they need to choose the second button, clicking 'Connect' will (probably?) not cause Tor Browser to try the bridges entered in the text box. Users may nevertheless think that the bridges they have entered actually were tried and found to be blocked/faulty/unreachable, when in reality it is the provided bridges that don't work.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by asn

Cc: asn added

comment:2 Changed 5 years ago by phoul

Cc: phoul added

comment:3 Changed 5 years ago by brade

Cc: mcs added

What OS are you using? What version of Tor Browser?

The behavior I see with TB 3.6.2 on Mac is that the radio button toggles as soon as you type or paste into the edit field for custom bridges.

comment:4 Changed 5 years ago by harmony

Resolution: not a bug
Status: newclosed

Ugh, you're right. I stupidly didn't even try typing in the box; for some reason I was expecting it to happen upon clicking. (Linux 32bit, for what it's worth).

Resolving as 'not a bug', I suppose. Sorry.

Note: See TracTickets for help on using tickets.