Opened 5 years ago

Closed 5 years ago

#12689 closed defect (duplicate)

Windows torrc should not be synced to other domains

Reported by: mttp Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: easy
Cc: gamambel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After the Windows expert bundle is installed, the torrc file gets automatically saved to the roaming part of user profiles, meaning it syncs with active directory on company servers, if they exist. All files in %appdata% get automatically synchronized to the domain server on computers that use one. If the user logs in to another machine on the same domain, her torrc will be copied there as well.

It might be better for torrc to live in the non-roaming "local" directory (%localappdata%), which means that it won't get synchronized across a domain.

The argument for using %appdata% is that it is more backwards compatible. On the other hand %localappdata% exists from WinXP SP 2 onwards.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

Seems like a duplicate of #7956 ? Please reopen if not.

Note: See TracTickets for help on using tickets.