Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12720 closed defect (not a bug)

tor-0.2.4.22 configure static fails unless -ldl -lz after -lcrypto

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.22
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

./configure --enable-static-tor --with-libevent-dir=/home/cypherpunks/libevent-2.0.21-stable --enable-static-openssl --with-openssl-dir=/home/cypherpunks/openssl-1.0.1h --with-zlib-dir=/home/cypherpunks/zlib-1.2.8

fails at checking on openssl directory

If I edit configure and I replace the line 7005:

LIBS="$tor_saved_LIBS -lssl -lcrypto $TOR_LIB_GDI"

with:

LIBS="-lssl -lcrypto $TOR_LIB_GDI $tor_saved_LIBS -lz"

then configure is complete and compilation is ok.

Please fix this for the next release.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by cypherpunks

On the first line of the ticket there was an extra parameter not needed (--enable-static-openssl)

  • ./configure --enable-static-tor --with-libevent-dir=/home/cypherpunks/libevent-2.0.21-stable --enable-static-openssl --with-openssl-dir=/home/cypherpunks/openssl-1.0.1h --with-zlib-dir=/home/cypherpunks/zlib-1.2.8

+ ./configure --enable-static-tor --with-libevent-dir=/home/cypherpunks/libevent-2.0.21-stable --with-openssl-dir=/home/cypherpunks/openssl-1.0.1h --with-zlib-dir=/home/cypherpunks/zlib-1.2.8

comment:2 Changed 5 years ago by cypherpunks

Resolution: not a bug
Status: newclosed

I am sorry for your trouble, I have compiled libevent using the INSTALL instructions of tor with the parameters --disable-shared --enable-static --with-pic and now it compiles fine without any configure edit.

Still I would be interested to learn from someone far more experienced in this if the order of -ldl -lz after -lcrypto is important.

Version 1, edited 5 years ago by cypherpunks (previous) (next) (diff)
Note: See TracTickets for help on using tickets.