Opened 5 years ago

Closed 3 years ago

#12745 closed defect (worksforme)

still running old version of Tor Button after upgrading TBB in-place

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Blocker Keywords: tbb-usability
Cc: gk, intrigeri Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I've been upgrading TBB by untarring the new one over my old one, to preserve my preferences and bookmarks. I've heard this is not recommended, but I haven't heard a better way to accomplish this goal and as I use TBB for everything I'd really like to have my preferences saved.

After upgrading to 3.6.3 I happened to notice I was running an outdated Tor Button. I investigated a bit but have been unable to determine how this happens. But, it is reproducible:

  1. Untar and run TBB 3.6.2 (on Linux, in my case)
  2. Quit TBB.
  3. Untar and run TBB 3.6.3
  4. Look at the versions of the extensions (under Tools->Add-ons).

In my case, the Tor Launcher and HTTPS Everywhere are the expected versions (what is listed in the 3.6.3 release notes), NoScript is newer (it auto-updates, apparently) and Tor Button is older. I confirmed that the file at tor-browser_en-US/Data/Browser/profile.default/extensions/torbutton@torproject.org.xpi contains the correct version (1.6.11.0) and I don't see any other tor button files in my tor-browser_en-US, so the old version must be getting cached somewhere.

I suspected this might be related to the fact that the file has an mtime of Jan 1 2000 (which I assume relates to the deterministic builds), but the other extensions which do update have that mtime too.

I was able to get the new version to run by removing the file from the extensions directory, running and quitting TBB, and then placing the file back there.

Child Tickets

Change History (12)

comment:1 Changed 5 years ago by gk

Cc: gk added
Component: - Select a componentTor Browser
Keywords: tbb-usability added
Owner: set to tbb-team

comment:2 Changed 5 years ago by cypherpunks

This is still happening with TBB 4.5a3, upgraded from current stable 4.0.3 using torbrowser-launcher.

This might be related to #11242 which was supposedly fixed.

comment:3 Changed 5 years ago by cypherpunks

More details: after upgrading TBB 4.0.3 -> 4.5a3 using the latest master of torbrowser-launcher, I have these versions (when I should have these versions):

  • HTTPS-Everywere 4.0.2 (should be 5.0developement.2)
  • NoScript 2.6.9.11 (release notes say 2.6.9.10)
  • TorButton 1.7.0.1 (should be 1.8.1.3, although 1701 is a lovely number)
  • TorLauncher 0.2.7.0.1 (should be 0.2.7.1)

I will now try the workaround I documented previously of stopping TBB, moving extensions away, starting, stopping, moving them back, and starting again.

comment:4 in reply to:  3 ; Changed 5 years ago by arma

Replying to cypherpunks:

More details: after upgrading TBB 4.0.3 -> 4.5a3 using the latest master of torbrowser-launcher

Wouldn't that upgrade path have been 4.5-alpha2 -> 4.5a3? And 4.0.2 -> 4.0.3? I don't think you can mix the stable and alpha branches like you're doing, with the internal updater.

comment:5 in reply to:  4 Changed 5 years ago by cypherpunks

I forgot to comment again yesterday that the moving extensions away and back *did* work again.

Replying to arma:

Wouldn't that upgrade path have been 4.5-alpha2 -> 4.5a3? And 4.0.2 -> 4.0.3? I don't think you can mix the stable and alpha branches like you're doing, with the internal updater.

I'm using torbrowser-launcher, which currently insists on upgrading 4.0.3 to 4.5a3 (I assume due to that version being in the RecommendedTBBVersions file and not having "alpha" in its version string). But when I filed this ticket in July I was upgrading manually (as described in the ticket) and had the exact same symptoms.

(I still haven't used the new internal updater on Linux successfully yet; I forget what happened execpt that it failed when I tried it last time so I'm still using TBL.)

I hope this issue won't be ignored if it happens to not affect the internal updater! Even if the internal updater works, I think/hope micahflee will continue to maintain TBL as long as there isn't an official TBB debian package.

comment:6 Changed 4 years ago by intrigeri

Cc: intrigeri added

comment:7 Changed 4 years ago by cypherpunks

This issue is still reproducible in the most recent alpha, 4.5a4, as mentioned in comments at https://blog.torproject.org/blog/tor-browser-405-released

comment:8 Changed 4 years ago by cypherpunks

Severity: Blocker

I just upgraded to 5.0.5 (from 5.0.4, using TBB's built-in upgrader on top of a TBB originally installed by torbrowser-launcher) and this time my Tor Launcher, Tor Button, and NoScript are all up to date but HTTPS Everywhere is 5.1.0 instead of 5.1.1.

comment:9 in reply to:  8 Changed 4 years ago by mcs

Replying to cypherpunks:

I just upgraded to 5.0.5 (from 5.0.4, using TBB's built-in upgrader on top of a TBB originally installed by torbrowser-launcher) and this time my Tor Launcher, Tor Button, and NoScript are all up to date but HTTPS Everywhere is 5.1.0 instead of 5.1.1.

Thanks for reporting this. I am not sure what is going on, but extensions should not be cached anywhere. Are you able to reproduce this problem reliably, e.g., by installing a fresh copy of 5.0.4 without torbrowser-launcher and then updating it to 5.0.5?

comment:10 Changed 4 years ago by mcs

Status: newneeds_information

comment:11 Changed 3 years ago by cypherpunks

OP here. Still using my ancient tor browser profile, originally via torbrowser-launcher but in recent months I've been using Tor Browser's updater and I currently appear to have the correct versions of Tor Button and Tor Launcher (looking at the last few releases' blog posts), and version N+1 of NoScript and HTTPS Everywhere (where N is the last version mentioned in a tor browser release blog post).

I guess this is fixed now? And those two extensions are auto-updating?

I doubt this would be helpful, but if it is, I could try to repro this with 5.0.4->5.0.5 (the last versions where I observed this happen) if someone can tell me where to download old versions.

I'll try to remember to check what happens again after the next update.

comment:12 in reply to:  11 Changed 3 years ago by mcs

Resolution: worksforme
Status: needs_informationclosed

Replying to cypherpunks:

OP here. Still using my ancient tor browser profile, originally via torbrowser-launcher but in recent months I've been using Tor Browser's updater and I currently appear to have the correct versions of Tor Button and Tor Launcher (looking at the last few releases' blog posts), and version N+1 of NoScript and HTTPS Everywhere (where N is the last version mentioned in a tor browser release blog post).

I guess this is fixed now? And those two extensions are auto-updating?

Yes, it sounds like it.

I doubt this would be helpful, but if it is, I could try to repro this with 5.0.4->5.0.5 (the last versions where I observed this happen) if someone can tell me where to download old versions.

Old versions are available here:
https://archive.torproject.org/tor-package-archive/torbrowser/

I am not sure it is worthwhile to try to reproduce this using an older version though you are welcome to try.

I'll try to remember to check what happens again after the next update.

Thanks. I am closing this ticket but please re-open or file a new ticket if the problem occurs again.

Note: See TracTickets for help on using tickets.