Opened 5 years ago

Closed 5 years ago

#12759 closed enhancement (duplicate)

don't regexp transport names

Reported by: cypherpunks Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords:
Cc: chingucha@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

regexps are slow. use hash. O(n) becomes O(1)

Child Tickets

Attachments (3)

Change History (8)

comment:1 Changed 5 years ago by cypherpunks

Status: newneeds_review

Changed 5 years ago by cypherpunks

comment:2 Changed 5 years ago by isis

Possible duplicate of #12504.

comment:3 in reply to:  2 Changed 5 years ago by cypherpunks

Replying to isis:

Possible duplicate of #12504.

s/duplicate/fix

comment:4 Changed 5 years ago by chingucha

Hey any updates on this? Anything I can do to speed up the code review?

comment:5 Changed 5 years ago by isis

Resolution: duplicate
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.