Opened 5 years ago

Closed 5 years ago

Last modified 4 months ago

#12763 closed defect (fixed)

-no-remote prevents using Tor Browser as default browser

Reported by: micahlee Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: torbrowser-launcher, tbb, default browser
Cc: themusicgod1 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm the author of Tor Browser Launcher. I'd like to make it possible for Linux users to easily set Tor Browser as their default browser. The start-tor-browser script now passes extra arguments into firefox when you run it, so you can run:

./start-tor-browser https://www.torproject.org/

Tor Browser will open to https://www.torproject.org/. But if you already have a Tor Browser window open and you run:

./start-tor-browser https://tails.boum.org/

It throws the error:

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

This is because the line that runs firefox is ./Browser/firefox -no-remote --class "Tor Browser" -profile Data/Browser/profile.default "${@}", and -no-remote prevents any remote commands such as opening new tabs: https://bugzilla.mozilla.org/show_bug.cgi?id=650078

How come firefox is run with -no-remote? I assume there's a reason behind it. Is it useful for privacy/anonymity/data minimization? Would it be bad to patch start-tor-browser to remove -no-remote?

As long as -no-remote is there, I don't think it's possible to set Tor Browser as your default browser.

Here's my upstream bug about this: https://github.com/micahflee/torbrowser-launcher/issues/103

Child Tickets

Change History (9)

comment:1 in reply to:  description Changed 5 years ago by bastik

Replying to micahlee:

How come firefox is run with -no-remote? I assume there's a reason behind it. Is it useful for privacy/anonymity/data minimization? Would it be bad to patch start-tor-browser to remove -no-remote?

I'm unaware of it being useful for anything else, other than to run TorBrowser and Firefox (vanilla) at the same time. Without no-remote it is not possible. I'm unaware of other ways to achieve this.

(Using no-remote for Firefox Portable, while running Firefox to compare them at the same time on Windows)

(I use Firefox and if I use TorBrowser, mainly for testing or comparison, I expect it to be possible to have both open at the same time. As far as I can tell it is a convenience feature.)

comment:2 Changed 5 years ago by mcs

It is safer to include -no-remote so that when someone starts Tor Browser they do not get a new Firefox window instead. I am not sure, but the --class "Tor Browser" argument may fix that problem too.

Regardless, for TB 4.0a1, we have removed -no-remote and patched Firefox so that -no-remote is the default behavior. The good news is that we also added support for a new -allow-remote option that overrides -no-remote and enables remoting, so with TB 4.x you should be able to get the behavior you want. See:

https://gitweb.torproject.org/builders/tor-browser-bundle.git/blob/HEAD:/RelativeLink/RelativeLink.sh

https://gitweb.torproject.org/tor-browser.git/commit/e9b44888df375ca2cf73e03eb580ca84516272e5

Be careful not to make it easy for people to get a Firefox or Iceweasel window when they think they are starting Tor Browser though.

comment:3 Changed 5 years ago by gk

So, we can close this ticket then as the problem is fixed on trunk?

comment:4 Changed 5 years ago by lunar

Do we want Tor Browser to become the default system browser? Correct me if I'm wrong, but I believe this has privacy implications. Applications would be able to easily open URLs within the Tor Browser, and link Tor activities with what they know about the system.

comment:5 in reply to:  4 Changed 5 years ago by mcs

Resolution: fixed
Status: newclosed

Replying to lunar:

Do we want Tor Browser to become the default system browser? Correct me if I'm wrong, but I believe this has privacy implications. Applications would be able to easily open URLs within the Tor Browser, and link Tor activities with what they know about the system.

I agree that applications may be able to take advantage of the fact that the Tor Browser is the default browser. I don't think making TB the system default is something the Tor Project is likely to recommend or do automatically, but some people may want to do so.

I am closing this bug.

comment:6 Changed 5 years ago by CRhode

I'm not able to open a new TBB 4.0 window with -new-window using an existing, running instance started with -allow-remote. I get a pop-up box saying, "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Here follows a sermon for the choir: Modern desktop environments rely on Web browsers to such an extent that they seem inseparable, e.g., Explorer and Windows (whatever-level). This is because the desktop invokes the browser to fire all kinds of URLs, to display PDFs, to render local HTML documents, to display images, to navigate folders, and even to display and print text, heaven forefend! I doubt it's possible for the desktop reliably to distinguish the contexts in which these different kinds of requests originate. I certainly don't think it's desirable. The one-size-fits all approach is universal and compelling. A browser with identical look and feel should be fired in every case.

I want to use TBB for surfing. Thus, I want to use it for everything else, too.

comment:7 Changed 5 years ago by CRhode

Further experimentation:

You probably need to specify -allow-remote on second and subsequent calls (not just the first one). Use it along with -new-tab or -new-window. I'm not sure whether --class is honored on second and subsequent calls. Anyway, it's all better now. -ccr-

comment:8 Changed 23 months ago by cacahuatl

Severity: Normal

See torbrowser-launcher's issue #157 for a graphic example of exactly how this goes wrong and why it shouldn't be attempted outside of carefully considered use-cases like Tails'.

comment:9 Changed 4 months ago by gk

Cc: themusicgod1 added

#29254 is a duplicate.

Note: See TracTickets for help on using tickets.