Opened 4 years ago

Closed 4 years ago

#12794 closed defect (fixed)

Nightly builds are not always using the latest git commits for building

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-gitian
Cc: ln5 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

By accident I looked at today's (8/5/2014) nightlies which showed the following commits used:

50893291621658f355bc5b4d450a8d06a563053d zlib.git
641c1584f7be8de88d3c58eae96c5c022a4870d1 tor.git
4f320dc92e59e35e318a32ffb67a91ffa6ccb439 tor-browser.git
2a8e082315364149fd64129bc56e6f861132a5d4 torbutton.git
6cf204d64cb8829ca4a7a8d3bc8d601ff4cf534d tor-launcher.git
21d392a190fbbde2eaf20e13350b0bedd49557aa https-everywhere.git
00133b8741eb8ca34fc8153d344c7c54a5e3fae9 tbb-windows-installer.git
9418eaa1854320b57f40e29ec5bbc4f5717ecd58 mingw-w64.git
ae72871ea2e1c731ee34bba27a47fcce1b79786e gitian-builder.git
f8f36e38ec419457d38ed4815aed802c327c30ae tor-browser-bundle.git

The nightlies should use an up-to-date master branch which is clearly not working (look e.g. at tor, https-everywhere and torbutton).

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by gk

A log from the fetch-inputs step would probably be a good start for tracking this issue down and fixing it.

comment:2 Changed 4 years ago by gk

To update this ticket I think at least part of the problem is:

./check-prerequisites.sh: 35: ./check-prerequisites.sh: kvm-ok: not found
./check-prerequisites.sh: 38: ./check-prerequisites.sh: kvm-ok: not found
make: *** [prep-nightly] Error 1

This leads to not executing

./fetch-inputs.sh ../../gitian-builder/inputs/ versions.nightly

in the prep-nightly target and makes the first try to build the nightly fail. All subsequent tries just run make build-nightly which is *not* calling fetch-inputs.sh. This leads to the situation that the build inputs are never updated (unless this happens manually).

comment:3 Changed 4 years ago by ln5

Weird. I'm unable to reproduce this outside the build proces.

I do have /usr/sbin/kvm-ok and it's found from shell scripts run from cron. Running check-prerequisites.sh using at(1) doesn't generate any complaints. I wonder what differs.

I've now added a symlink /usr/sbin/kvm-ok -> /usr/bin/kvm-ok (ugh). This system is being reinstalled (which has been true for months now, hmm).

comment:4 Changed 4 years ago by gk

Resolution: fixed
Status: newclosed

Comparing the output from 20140120 and 20140128 I'd say this is fixed. Thanks!

Note: See TracTickets for help on using tickets.