Opened 5 years ago

Closed 2 years ago

#12840 closed defect (worksforme)

certificate patrol (addon) install error with Tor-Browser german/italian language 3.6.2/3.6.4

Reported by: Systemshocker Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Dear Tor Developers,

Since the release of the tor-browser bundle 3.6.2 for linux, I see a
strange error when tying to install the firefox add-on "certificate
patrol 2.0.14".
The tor-browser aborts the installation with the message that an error appeared during the installation. Moreover it calls the addon name "null".
The Browser Terminal displays the following error on that issue.

[14:24:13.463] WARN addons.xpi: Download failed: TypeError:

aAddon._repositoryAddon is null @
resource://gre/modules/XPIProvider.jsm:4788

This happens not only when trying to install the addon from the
mozilla server, but also when trying to install it from file.

Finally, I have testet the addon on other firefox profiles. None of
them displayed that error and the installation of certificate patrol worked
like a charm. So it seems to be that the error comes from the tor-
browser.

The certificate patrol addon may be old, but it is the only firefox
addon, which can detect if an ssl cert is renewed/switched on an
website (without sending any data trough the web).
This can help against an man-in-the-middle attack on ssl
connections.
Therefore, I consider that install error of that addon a problem.

So please take a look at that issue.....just to see, if its related to
the tor-browser or to a completely different source.

Sincerely,
Systemshocker

Child Tickets

Attachments (2)

TBB-en_US-2014-08-25 21:44:48.png (140.7 KB) - added by Systemshocker 5 years ago.
addon install on en_US bundle
TBB-de-2014-08-25 21:47:40.png (117.7 KB) - added by Systemshocker 5 years ago.
addon error on de bundle

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by gk

Resolution: worksforme
Status: newclosed

Works for me on different Linux systems both with 3.6.4 and 4.0-alpha-1. Not sure what is wrong on your side. Feel free to contact the help desk for support.

Changed 5 years ago by Systemshocker

addon install on en_US bundle

Changed 5 years ago by Systemshocker

addon error on de bundle

comment:2 in reply to:  1 Changed 5 years ago by Systemshocker

Replying to gk:

Works for me on different Linux systems both with 3.6.4 and 4.0-alpha-1. Not sure what is wrong on your side. Feel free to contact the help desk for support.

I had forgot to add one important information, sorry.
The problem only appears in the german language package of the browser-bundle.
The en_US bundle is not affected by that.

Had just testet the installation of the certificate patrol addon with an german package of the 3.6.4 32bit bundle for linux and with an en_US package of the same version.
Screenshots have been added.
In the en_US version -> installation worked.
In the de version -> error

Could be a error in that language package.

However, I will switch now to the en_US package.

comment:3 Changed 5 years ago by Systemshocker

Resolution: worksforme
Status: closedreopened

comment:4 Changed 5 years ago by Systemshocker

Priority: normalminor
Summary: certificate patrol (addon) install error with Tor-Browser 3.6.2certificate patrol (addon) install error with Tor-Browser german language 3.6.2/3.6.4

comment:5 Changed 5 years ago by gk

Summary: certificate patrol (addon) install error with Tor-Browser german language 3.6.2/3.6.4certificate patrol (addon) install error with Tor-Browser german/italian language 3.6.2/3.6.4

comment:6 Changed 5 years ago by gk

#11817 breaks this although why this happens is still not clear. Surprisingly vanilla Firefox is working fine, even if one tries to "simulate" Tor Browser behavior by using an en-US browser + a german or italian (those languages Certificate Patrol supports) language pack.

comment:7 Changed 5 years ago by gk

Keywords: addon install error removed
Priority: minornormal

comment:8 in reply to:  6 Changed 5 years ago by gk

Resolution: not a bug
Status: reopenedclosed

Replying to gk:

Surprisingly vanilla Firefox is working fine, even if one tries to "simulate" Tor Browser behavior by using an en-US browser + a german or italian (those languages Certificate Patrol supports) language pack.

That was a bit too fast, I forgot to set extensions.getAddons.cache.enabled to false. Doing so I can see the same issue with a vanilla Firefox. I'd say this is a Certificate Patrol bug. Please, contact the authors and hopefully they'll fix it. Thanks!

comment:9 Changed 5 years ago by gk

Resolution: not a bug
Status: closedreopened

Let's call it at least a bug, as some Tor Browser change breaks the installation of the extension. Nevertheless, I still think the Certificate Patrol authors should fix the extension.

comment:10 Changed 4 years ago by vynX

I have no problems using Certificate Patrol with the current version of Tor Browser. I would instead recommend it for shipping with Tor Browser so that MITM attacks are easier to spot. Maybe it was a problem on the Firefox side of things that got fixed in the meantime? Do you still see the problem? Can you explain what goes wrong or spot the offending Javascript?

comment:11 Changed 2 years ago by cypherpunks

Resolution: worksforme
Severity: Normal
Status: reopenedclosed
Note: See TracTickets for help on using tickets.