Opened 5 years ago

Closed 5 years ago

#12896 closed defect (worksforme)

ContactInfo not added with a SIGHUP

Reported by: cypherpunks Owned by: karsten
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor version 0.2.5.6-alpha (git-4410634e67a43952).

Hello,

Sending a SIGHUP (or a reload in arm, which does the same thing) fails to make the relay add contact details to the consensus. This was verified using globe. However, once I restarted said relays, the contact info appeared as soon as the next consensus was generated.

I have not tried modifying the ContactInfo contents to see if they are recognised with a SIGHUP/reload.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by cypherpunks

OP: I noticed this when trying to sign up relays to https://oniontip.com/.

comment:2 Changed 5 years ago by donncha

Component: - Select a componentOnionoo

I investigated this issue briefly. The correct updated contact information was being shown on torstatus.blutmagie.de but not on Atlas or Globe. torstatus.blutmagie.de directly loads it's data from cached tor consensus files where as Atlas, Globe and Oniontip all source their data from Onionoo. It seems this particular issue is a bug in the Onionoo service rather than in the contact data being updated in the network consensus.

comment:3 Changed 5 years ago by donncha

Owner: set to karsten
Status: newassigned

It seems like this issue may have been caused by the same Onionoo bug Karsten fixed in https://gitweb.torproject.org/onionoo.git/commitdiff/8c0b411537449b25ebb35cbac8e3cc4e3813f182

comment:4 Changed 5 years ago by karsten

Status: assignedneeds_information

There was indeed a bug with updating contact information, which is fixed by now. cypherpunks, can you attempt to reproduce the issue and write down exact timestamps of all your actions? If you can reproduce the issue, be sure to mention the relay fingerprint here. Thanks!

comment:5 Changed 5 years ago by karsten

Resolution: worksforme
Status: needs_informationclosed

Assuming the bug is now fixed. If not, please re-open.

Note: See TracTickets for help on using tickets.