Opened 5 years ago

Closed 5 years ago

#12912 closed defect (duplicate)

AutomapHostsOnResolve often returns real IP

Reported by: operator_from_earth Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: transparent proxy, virtual ip address, AutomapHostsOnResolve
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

I'm running a small node for years. Few months ago a started using auto-mapping hosts to virtual IP. Tor often returns real IP address instead of virtual one. For example:

root@host:~# host www.torproject.org
www.torproject.org has address 38.229.72.14
www.torproject.org has address 38.229.72.14
Host www.torproject.org not found: 4(NOTIMP)

I have to send HUP signal to the running process to return to normal behavior:

root@host:~# host www.torproject.org
www.torproject.org has address 10.230.198.145
www.torproject.org has address 10.230.198.145
Host www.torproject.org not found: 4(NOTIMP)

But after several hours or minutes tor begin returning real addresses again, after sending SIGHUP it's OK or several hours/minutes.

Currently i'm running tor 0.2.4.23 (git-598c61362f1b3d3e).

I created crontab entry, it sends SIGHUP every hour, but it's not enough.

See attached config file.

Best regards

Child Tickets

Attachments (1)

tor.conf (1.2 KB) - added by operator_from_earth 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by operator_from_earth

Attachment: tor.conf added

comment:1 Changed 5 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: 0.2.6.x-final
Resolution: duplicate
Status: newclosed

This should be solved in 0.2.6.3-alpha; it appears to be a duplicate of #12509

Note: See TracTickets for help on using tickets.