Opened 5 years ago

Closed 2 years ago

#12940 closed enhancement (duplicate)

Separate configuration parameters for separate client ports

Reported by: brainchild Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In many cases, a Tor user might want to use multiple simultaneous Tor identities, possibly with separate configuration parameters, such as the country of the exit node.  The identity used to route a particular outgoing packet might depend on, for example, the particular web site visited or the client process initiating the packet.  Processing of these rules need not be handling by Tor.  Rather, the user might configure rules through the browser or through invocation the torsocks script.  The role of Tor need be nothing more than processing SOCKS requests on multiple ports, each one corresponding to a distinct configuration.  In principle, this functionality can be achieved by invoking multiple instances of the Tor process.  However, this arrangement is often difficult to configure.  On the Tor distribution for Ubuntu, for instance, it may require making multiple copies of the configuration file and the init script configured to use distinct log dirs, cookie files, and so on.  A far more elegant solution would be to configure a single instance of the Tor process to use multiple sets of configuration parameters corresponding to separate SOCKS ports.  In order for this solution to be possible, however, a feature enhancement would need to be introduced to the codebase.

Child Tickets

Change History (7)

comment:1 Changed 5 years ago by nickm

Milestone: Tor: 0.2.???

comment:2 Changed 5 years ago by nickm

Summary: multiple simultaneous tor identitiesSeparate configuration parameters for separate client ports

comment:3 Changed 5 years ago by arma

Seems like a lot of work to get right -- I guess step one is to identify exactly which config parameters you wanted to be per-socksport. And no matter how you build your list, somebody else is going to find your list unintuitive and surprising. :(

comment:4 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:5 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:6 Changed 2 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:7 Changed 2 years ago by nickm

Resolution: duplicate
Severity: Normal
Status: newclosed

Closed as duplicate of #6883

Note: See TracTickets for help on using tickets.