Opened 5 years ago

Closed 5 years ago

#12983 closed defect (duplicate)

TBB hangs on startup, no browser window

Reported by: Emory Hubbard Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

New user, have been enjoying Tor for a couple days now. Windows 7.

The Usual: connection window pops up, completes. After it disappears, browser window opens. Everything works well.
The Sometimes: connection window pops up, completes. After it disappears, browser window does not open, and there's no response for at least 6 min. I just end the process after that.

Turned on some logging. Closed the browser, reopened the browser, and repeated. It seems on the 6th try, got the Sometimes-hang. A difference from the other sessions was that no "New control connection opened" was logged at the end. Here are the last two sessions, one Usual and then the Sometimes.

Aug 29 04:20:58.000 [notice] Tor 0.2.4.23 (git-a9ea51dc0bd48126) opening log file.
Aug 29 04:20:58.000 [notice] Pluggable transport proxy (fte exec Tor\PluggableTransports\fteproxy --managed) does not provide any needed transports and will not be launched.
Aug 29 04:20:58.000 [notice] Pluggable transport proxy (obfs2,obfs3 exec Tor\PluggableTransports\obfsproxy managed) does not provide any needed transports and will not be launched.
Aug 29 04:20:58.000 [notice] Pluggable transport proxy (flashproxy exec Tor\PluggableTransports\flashproxy-client --register :0 :9000) does not provide any needed transports and will not be launched.
Aug 29 04:20:58.000 [notice] Parsing GEOIP IPv4 file C:\Users\edh\Desktop\Tor Browser\Data\Tor\geoip.
Aug 29 04:20:59.000 [notice] Parsing GEOIP IPv6 file C:\Users\edh\Desktop\Tor Browser\Data\Tor\geoip6.
Aug 29 04:21:03.000 [notice] We now have enough directory information to build circuits.
Aug 29 04:21:03.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Aug 29 04:21:03.000 [notice] New control connection opened.
Aug 29 04:21:03.000 [notice] Tor 0.2.4.23 (git-a9ea51dc0bd48126) opening log file.
Aug 29 04:21:03.000 [notice] Pluggable transport proxy (fte exec Tor\PluggableTransports\fteproxy --managed) does not provide any needed transports and will not be launched.
Aug 29 04:21:03.000 [notice] Pluggable transport proxy (obfs2,obfs3 exec Tor\PluggableTransports\obfsproxy managed) does not provide any needed transports and will not be launched.
Aug 29 04:21:03.000 [notice] Pluggable transport proxy (flashproxy exec Tor\PluggableTransports\flashproxy-client --register :0 :9000) does not provide any needed transports and will not be launched.
Aug 29 04:21:03.000 [notice] New control connection opened.
Aug 29 04:21:03.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Aug 29 04:21:03.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Aug 29 04:21:05.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Aug 29 04:21:06.000 [notice] Bootstrapped 100%: Done.

I don't expect this to be too useful, matter much, or be reproducible for others. I ran across it when I was trying to set Tor Browser to be the default browser with the options pane. I couldn't get that to work. Don't know why. However, if someone has seen this before or if something is obviously wrong, let me know what it is.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed
Version: Tor: 0.2.4.22

Duplicate of #10804.

Note: See TracTickets for help on using tickets.