Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#13032 closed defect (not a bug)

"Ticket URL:" link in eMails includes ending '>', fails

Reported by: LorenAmelang Owned by:
Priority: Medium Milestone:
Component: Internal Services/Service - trac Version:
Severity: Keywords: confirmation eMail link
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As the title says, my confirmation eMail includes the line:

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/12952>

The beginning '<' is not underlined and does not propagate to the browser. The ending '>' is underlined and does propagate to my browser, producing:

Error: Not Found
No handler matched request to /ticket/12952>

Until I looked very carefully, I thought you had deleted my ticket...

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by karsten

Component: - Select a componentTrac
Resolution: not a bug
Status: newclosed

That sounds like a problem with your email client. Trac sends text-only mails, it's your email client that converts text to links. And apparently it's doing it wrong. Here's the email body of this ticket's message:

#13032: "Ticket URL:" link in eMails includes ending '>', fails
-------------------------------------+---------------------
 Reporter:  LorenAmelang             |          Owner:
     Type:  defect                   |         Status:  new
 Priority:  normal                   |      Milestone:
Component:  - Select a component     |        Version:
 Keywords:  confirmation eMail link  |  Actual Points:
Parent ID:                           |         Points:
-------------------------------------+---------------------
 As the title says, my confirmation eMail includes the line:

 Ticket URL: <https://trac.torproject.org/projects/tor/ticket/12952>

 The beginning '<' is not underlined and does not propagate to the browser.
 The ending '>' is underlined and does propagate to my browser, producing:

 Error: Not Found
 No handler matched request to /ticket/12952>

 Until I looked very carefully, I thought you had deleted my ticket...

--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/13032>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online
_______________________________________________
tor-bugs mailing list
tor-bugs@lists.torproject.org
https://lists.torproject.org/cgi-bin/mailman/listinfo/tor-bugs

Closing as "not a bug". If you meant something else, please re-open.

comment:2 Changed 4 years ago by qbi

Component: TracService - trac

Move all tickets from trac to "Service - trac" component.

Note: See TracTickets for help on using tickets.