Opened 5 years ago

Closed 5 years ago

#13050 closed defect (duplicate)

system locale leaked via JavaScript Date.toLocaleString() format

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using the en_US Tor Browser 3.6.5 on Linux, with the system set to a non-English locale.

When I visit http://browserspy.dk/date.php, the time is displayed as UTC, but the "Locale String"/"Time on your PC" tests show the time in the format of the non-English system locale.

Both of these tests print the value of the JavaScript Date.toLocaleString() method.

I can control the format used by toLocaleString() by explicitly setting the LANG environment variable when running start-tor-browser.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #5926.

Note: See TracTickets for help on using tickets.