Opened 5 years ago

Closed 5 years ago

#13099 closed task (duplicate)

Buy .onion nTLD

Reported by: saint Owned by:
Priority: Low Milestone:
Component: - Select a component Version:
Severity: Keywords: SponsorZ
Cc: griffin@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Given the recent expiration of the "Special-Use Domain Names of Peer-to-Peer Systems" IETF draft, it might be useful to revisit the possibility of purchasing exclusive use of the .onion TLD.

[1] https://datatracker.ietf.org/doc/draft-grothoff-iesg-special-use-p2p-names/

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by saint

Cc: griffin@… added
Priority: normalminor

comment:2 Changed 5 years ago by arma

Resolution: duplicate
Status: newclosed

People keep suggesting this. But last I checked, and I don't think this will change anytime soon, it costs hundreds of thousands of dollars to apply to maybe be able to actually pay them more to get the domain. This domain monopoly from icann is silly and not really something we should waste our time supporting -- especially since we can simply route around them.

Closing as duplicate of #6116 which is another of these tickets.

Note: See TracTickets for help on using tickets.