Opened 5 years ago

Closed 5 years ago

#13156 closed enhancement (duplicate)

Add "Stop Tor" option

Reported by: overview8 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tor, tor button, torbrowser, stop tor
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There's no option to stop Tor in TB, and File>Work Offline only stop the browser but Tor is still making connections.
Please add "Stop Tor" option, preferably to the Tor button.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by arma

Component: - Select a componentTor Browser
Owner: set to tbb-team

Is this best done in Torbutton, in Tor Launcher, or not at all?

comment:2 in reply to:  description Changed 5 years ago by gk

Replying to overview8:

Please add "Stop Tor" option, preferably to the Tor button.

Why should we add such a feature at all?

comment:3 Changed 5 years ago by arma

One reason would be to tell your Tor to stop making network connections -- maybe you've moved to a network that you're uncomfortable making/attempting Tor circuits on, but you don't want to close the tabs on your Tor Browser yet. Effectively it would be the same as setting DisableNetwork on and off.

(I think there's another overlapping ticket out there somewhere? I remember some discussion from Lunar et al about a phrase including "offline".)

comment:4 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Okay. I think the way to go would be not having a separate button to stop/start tor. Rather we should stop tor if a user checks "Work Offline" and start it again when she unchecks it. It does not make much sense to uncheck "Work Online" and haven't tor started/running in the Tor Browser context. Marking this therefore as a duplicate of #9541.

Note: See TracTickets for help on using tickets.