Opened 6 years ago

Closed 6 years ago

#13205 closed defect (fixed)

setevents will accept anything for second and later arguments

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

setevents hsdesc
552 Unrecognized event "hsdesc"
setevents circ hsdesc
250 OK

Notice how event_code never gets set back to -1 in the outer loop of handle_control_setevents().

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by arma

discovered by "fpxnns" on irc

comment:2 Changed 6 years ago by arma

Looks like it was introduced in git commit ca6efcf5

comment:3 Changed 6 years ago by arma

Status: newneeds_review

my bug13205 branch has a possible fix

comment:4 Changed 6 years ago by arma

Or is this better for 0.2.6 since it's not really a big deal?

comment:5 Changed 6 years ago by nickm

I lean towards merging this in 0.2.6, since it's not a regression, and there could be some (busted) controller out there that's doing the equivalent of "SETEVENTS circ hdesc" without checking the Tor version. Let's not break controllers so late in the 0.2.5.x series without a more urgent reason. (If you agree, please change the milestone to 0.2.6; you can merge it into 0.2.6 too if you like)

comment:6 Changed 6 years ago by arma

Milestone: Tor: 0.2.5.x-finalTor: 0.2.6.x-final
Resolution: fixed
Status: needs_reviewclosed

merged into 0.2.6

Note: See TracTickets for help on using tickets.