Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13224 closed defect (fixed)

Intermittent Tor startup

Reported by: astabula Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor 3.6.5 was downloaded and installed without issue on a Win 7, 32 bit system. First startup of Tor was OK, with the Tor connection status popup opening and closing, followed by opening of the Firefox browser. Shutdown was OK and both Tor and Firefox were closed out as confirmed by checking in Windows process explorer. Upon attemting a restart of Tor, the connection status window opened and closed as before, but the Firefox window would not open after 5 minutes. Windows process explorer showed Firefox and Tor to be running. No error messages were received. Tor was then deleted and reinstalled and the exact same effects as described above occurred. A third attempt was made trying to run Tor "as an administrator" but the exact same effects occurred.

Firefox v. 32.0.2 is also resident on the system but was not running. This version was removed and Tor was deleted; and then Tor was reinstalled. This time Tor could be opened and closed without difficulty multiple times by "running as administrator". Tor was then closed and Firefox v.32.0.2 was reinstalled. The exact effect occurred as originally described above. Tor versions prior to 3.6.3 did not exhibit this issue on my system.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by astabula

Resolution: fixed
Status: newclosed

Resolution: Connection setting in Advanced system options of browser was incorrectly set to "manual proxy configuration" rather than "use system proxy settings". Not sure how this was set incorrectly since clean browser installs were performed by deleting all file and registry entries related to Tor Browser before new installation.

Last edited 5 years ago by astabula (previous) (diff)

comment:2 in reply to:  1 Changed 5 years ago by gk

Replying to astabula:

Resolution: Connection setting in Advanced system options of browser was incorrectly set to "manual proxy configuration" rather than "use system proxy settings".

No. The proxy settings in Tor Browser *are* set to "manual proxy configuration" by default. A SOCKS proxy with 127.0.0.1:9150 should be selected. It seems there is something else wrong with your system. Feel free to contact the support for further help: https://www.torproject.org/about/contact.html.en.

Note: See TracTickets for help on using tickets.