Opened 5 years ago

Closed 5 years ago

Last modified 8 months ago

#13235 closed defect (duplicate)

private mode / cookies settings not working, starting Tor browser not working

Reported by: Samonym Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm new to using Tor and wanted to try it out.

I'm running the Tor browser bundle 3.6.5:

a)from a pendrive on a Windows XP system

b) from an installed version on the desktop of a Windows 7 system in a virtual box (Oracle) and have observed some things I do not understand:

  1. Sometimes the grey small window opens telling: Tor is opened, but then the browser window doesn't open.

When clicking on „Start Tor browser. exe“ again, a small window says: Tor was running already, so I have to stop the Tor browser by the task-manager or by the ccleaner.

Sometimes I have to repeat that several times until the browser window of Tor opens

  1. If a website only works with cookies, you can change settings from „never remember history“ to „use custom settings for history“ and „accept cookies from sites“ in the normal Firefox and you can change the settings back again to „never remember history“ again and you have to close and restart Firefox. This does not work in the Tor browser, which does not save the „never remember history“-setting. You can choose the box „never remember history“ , click on „ok“, but if you open the options window again, you will see that the Tor browser is still on „use custom settings for history“ and „accept cookies“.

If you choose „always use private browsing mode“ no history or any data should be stored by the usual Firefox, right? So, you should not see anything under „history“. However, this is not the case with the Tor browser!!! The Tor browser keeps the history despite having chosen the private mode!!!

Last point: If you change the parameters and allow cookies and you were on sites that use cookies, they should be displayed under „show cookies“ - but there aren't any cookies displayed. Also ccleaner doesn't show any cookies stored. However, there must be cookies, because I was on sites that demand cookies otherwise they just don't work. So, where are the cookies? They must be on the system. With the usual Firefox you can see at least that cookies were set and you can control and delete them. And if flash cookies had been set you can control that by the ccleaner. But with the Tor browser you even can't see that any kind of cookie was set even though they must have been set.

I really cannot imagine that this behaviour of the Tor browser is intended.

Please let me know if there is something wrong with the Tor browser or if I am wrong. I would be grateful for a quick answer, because I'm really concerned about the matter and cannot rely on the Tor browser at all at the moment.

Thank you a lot for your quick response in advance!

Child Tickets

Change History (1)

comment:1 in reply to:  description Changed 5 years ago by gk

Keywords: tbb-usability added; cookies. private mode browser window removed
Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

Replying to Samonym:

I'm new to using Tor and wanted to try it out.

I'm running the Tor browser bundle 3.6.5:

a)from a pendrive on a Windows XP system

b) from an installed version on the desktop of a Windows 7 system in a virtual box (Oracle) and have observed some things I do not understand:

  1. Sometimes the grey small window opens telling: Tor is opened, but then the browser window doesn't open.

This is likely #10804 and should be better now.

  1. If a website only works with cookies, you can change settings from „never remember history“ to „use custom settings for history“ and „accept cookies from sites“ in the normal Firefox and you can change the settings back again to „never remember history“ again and you have to close and restart Firefox. This does not work in the Tor browser, which does not save the „never remember history“-setting. You can choose the box „never remember history“ , click on „ok“, but if you open the options window again, you will see that the Tor browser is still on „use custom settings for history“ and „accept cookies“.

If you choose „always use private browsing mode“ no history or any data should be stored by the usual Firefox, right? So, you should not see anything under „history“. However, this is not the case with the Tor browser!!! The Tor browser keeps the history despite having chosen the private mode!!!

Not sure what you mean here. Does this happen with a default Tor Browser you just freshly downloaded? Please, file a new ticket with steps to reproduce your problem as putting more than one issue in a ticket makes it hard to act on it, thanks.

Last point: If you change the parameters and allow cookies and you were on sites that use cookies, they should be displayed under „show cookies“ - but there aren't any cookies displayed. Also ccleaner doesn't show any cookies stored. However, there must be cookies, because I was on sites that demand cookies otherwise they just don't work. So, where are the cookies? They must be on the system. With the usual Firefox you can see at least that cookies were set and you can control and delete them. And if flash cookies had been set you can control that by the ccleaner. But with the Tor browser you even can't see that any kind of cookie was set even though they must have been set.

This is a Mozilla bug which is tracked on our side as #10353. I guess 2. is a duplicate as well (if it is an issue at all). Thus, resolving this whole ticket as duplicate.

Note: See TracTickets for help on using tickets.