Opened 3 years ago

Closed 3 years ago

#13356 closed defect (fixed)

symlinks missing after complete MAR file update

Reported by: mcs Owned by: mcs
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: TorBrowserTeam201410, ff31-esr, MikePerry201410R
Cc: brade, mikeperry, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While testing using MAR files from our own nightly build, brade and I discovered that the meek symlinks (present on Mac OS) are removed after a complete MAR update is applied to TB 4.0-alpha-3. The problem is in the MAR file generation – specifically, we neglected to include the addsymlink directives in the updatev2.manifest file (we only put them in the new updatev3.manifest file that is used by ESR31 and newer browsers).

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by mcs

Cc: brade mikeperry gk added
Keywords: added
Owner: changed from tbb-team to mcs
Status: newassigned

comment:2 Changed 3 years ago by mcs

Keywords: TorBrowserTeam201410 MikePerry201410R added; removed
Status: assignedneeds_review

A tested fix is here (on the branch bug4234-esr31-fixup-01):

https://gitweb.torproject.org/user/brade/tor-browser.git/commit/5630a27f53486655c14eae06276989f4e10632ef

mikeperry or gk: please review and merge into the main tor-browser repo.

comment:3 Changed 3 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Looks OK. Pushed to tor-browser-31.1.1esr-4.x-1. Should be in the next nightly.

Note: See TracTickets for help on using tickets.