Opened 5 years ago

Closed 5 years ago

#13402 closed defect (not a bug)

Stem does not allow for overriding of Directory Authorities

Reported by: tom Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Stem does not allow a library to override the Directory Authorities that are hardcoded in it.

A commit that does this is available at https://github.com/tomrittervg/stem/commits/override-authorities I have not tested it extensively, but usage in DocTor indicates that it seems to work.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by atagar

Hi Tom. What's wrong with callers simply doing the following?

stem.descriptor.remote.DIRECTORY_AUTHORITIES = authorities

Honestly overriding authorities isn't something callers should do. The remote module lets you define the relays to query instead of the authorities (they're just defaults). The trouble here seems more to be that DocTor isn't it making it easy to point elsewhere.

comment:2 in reply to:  1 Changed 5 years ago by tom

Replying to atagar:

Hi Tom. What's wrong with callers simply doing the following?

stem.descriptor.remote.DIRECTORY_AUTHORITIES = authorities

Nothing in particular. =) Feel free to close as Invalid, this was just something I ran into.

comment:3 Changed 5 years ago by atagar

Resolution: not a bug
Status: newclosed

Gitcha. I get the sense you're looking to monitor a separate tor network. Feel free to submit a DocTor patch for customizing the authorities it monitors if that would make your life easier.

Note: See TracTickets for help on using tickets.