Opened 3 years ago

Closed 11 months ago

#13430 closed defect (duplicate)

Can't set custom http-proxy on GnuPG-settings, lost after restart

Reported by: jarrod.ewing Owned by: ioerror
Priority: Medium Milestone:
Component: Applications/TorBirdy Version:
Severity: Normal Keywords: GnuPG, http-proxy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using Polipo as an HTTP-proxy over Tor, which is listening on port 8123.
If I'm searching the keyserver for keys with Enigmail, it does not work, because the default setting is "http-proxy=http://127.0.0.1:8118".
If I'm changing this setting to "http-proxy=http://127.0.0.1:8123", it works, but is reset after the restart of Icedove.

Please add the opportunity on the settings-menu to permanently set GnuPG-HTTP-proxy.

TorBirdy-Version: 0.1.2

Best regards,
Jarrod

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by sukhbir

Yes, TorBirdy will override any preference you set (except the ones that you can change using the preferences menu.)

Can't you just set Polipo to listen on port 8118 instead of 8123? That IMO sounds like the easiest option (The reason we don't have an option to configure this setting is because we wanted to have a HTTP to SOCKS5 shim, but it never came to that.)

comment:2 Changed 2 years ago by proper

Severity: Blocker

When using the torbirdy Debian package, can one use the config file /etc/xul-ext/torbirdy.js to specify the --keyserver-options setting?

comment:3 Changed 2 years ago by proper

Severity: BlockerNormal

comment:5 Changed 16 months ago by anon

Anyway to save custom settings to not be replicated, as TorBirdy currently breaks Enigmail keyserver support.

OS Arch Linux
GPG 2.1.14

TorBirdy 0.2

Needs to be set up for
--no-emit-version --no-comments --display-charset utf-8 --keyserver-options no-auto-key-retrieve

After restart it goes back to
--no-emit-version --no-comments --display-charset utf-8 --keyserver-options no-auto-key-retrieve,no-try-dns-srv,http-proxy=socks5h://127.0.0.1:9150

comment:6 Changed 12 months ago by intrigeri

This seems to be related to #16935 and #19971.

comment:7 Changed 11 months ago by intrigeri

Resolution: duplicate
Status: newclosed

Let's treat this as a duplicate of #16935, which is a superset of this one.

Note: See TracTickets for help on using tickets.