Opened 5 years ago

Closed 5 years ago

#13438 closed defect (not a bug)

TB menu button missing (TB v4.0)

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This seems to be the same problems from 3 years ago:
#4795

Now for v4.0, at least on Win 7, Aero Windows theme isn't loading and the "About Tor" (options) is broken (no clickable buttons).

See:
http://i.imgur.com/Fr3UyJL.png

Child Tickets

Attachments (5)

TB v4.0 Aero broken again.png (43.2 KB) - added by cypherpunks 5 years ago.
Screenshot of problem
TB v4.0 Aero not broken - but buttons still missing.png (63.1 KB) - added by cypherpunks 5 years ago.
TB v3.6.5 working button upper left hand corner.png (50.5 KB) - added by cypherpunks 5 years ago.
Vanilla Firefox buttons.png (41.1 KB) - added by cypherpunks 5 years ago.
TB v4.0 menue bar.png (60.5 KB) - added by cypherpunks 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by cypherpunks

Screenshot of problem

comment:1 in reply to:  description Changed 5 years ago by cypherpunks

Well I was dumb and forgot I disabled Windows Aero theme! So checking with Aero enabled and TB works fine in terms of theme support.

However, the buttons are still missing. See the second attached screenshot.

Sorry for the misfire.

Last edited 5 years ago by cypherpunks (previous) (diff)

comment:2 Changed 5 years ago by gk

Looks actually good to me. Which buttons are missing that the vanilla Firefox ESR 31 has by default?

comment:3 Changed 5 years ago by cypherpunks

See the two following screenshots.

All the buttons on the upper left are missing from Vanilla FF 'File,' 'Edit,' 'View,' 'History,' 'Bookmarks,' 'Help.' However, that's not the issue here, the normal (orange) TB button is missing in upper left hand corner.

I attached vanilla FF (v32.03) and TB (v3.6.5).

Thanks for the fast response and great work you do! :)

Last edited 5 years ago by cypherpunks (previous) (diff)

Changed 5 years ago by cypherpunks

Changed 5 years ago by cypherpunks

Attachment: Vanilla Firefox buttons.png added

comment:4 Changed 5 years ago by cypherpunks

And this screenshot shows TB v4.0 with the menu bar shown (right click > tick 'Menu Bar'). But the TorBrowser button (orange one) is still missing:

Changed 5 years ago by cypherpunks

Attachment: TB v4.0 menue bar.png added

comment:5 Changed 5 years ago by cypherpunks

And now I think about this, this doesn't seem to be related to #4795.

If you want to change the title, etc., be my guest.

comment:6 Changed 5 years ago by cypherpunks

Priority: majornormal
Summary: TBB does not like the standard theme on Windows XP, Vista, and 7 (part 2)TB menu button missing (TB v4.0)

comment:7 Changed 5 years ago by mcs

The orange "Tor Browser" button has been replaced with a "hamburger" menu (located on the right end of the browser's navigation toolbar). This is a change that Mozilla made for Firefox; we had no choice but to adopt this new user interface as well. Here is some more info that might help clarify: https://support.mozilla.org/en-US/questions/997275

Or are you asking about something else?

comment:8 Changed 5 years ago by cypherpunks

Resolution: not a bug
Status: newclosed

Ah. I didn't notice that replaced the orange button. I guess FF is really now a Chrome wanna be (j/k)!

Thanks.

Note: See TracTickets for help on using tickets.