Opened 5 years ago

Closed 5 years ago

#13475 closed defect (duplicate)

TOR V4 not working on Win7 32bit

Reported by: Hoo170 Owned by: tbb-team
Priority: High Milestone: Tor: unspecified
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have had v3.6.6 working fine but foolishly clicked on the upgrade onion.

Having upgraded it will not now work.

Firefox does start but shuts down shortly after.

Child Tickets

Change History (15)

comment:1 Changed 5 years ago by mcs

Thank you for filing a ticket.

I assume Firefox is crashing?
Does the crash occur after opening certain web sites? If so, this problem may be a duplicate of the one described in #13443.

comment:2 Changed 5 years ago by Hoo170

Hi thanks for replying so quickly.

I am starting the v4 Tor Browser and I can see from Task manager that Firefox is running with the description "Tor". It last for about 2030 seconds and then closes. No actual window opens and the home page is the standard Tor page.

Regards,

Steve.

comment:3 Changed 5 years ago by Hoo170

that is 20 or 30 seconds.

comment:4 Changed 5 years ago by Hoo170

that is 20 or 30 seconds.

comment:5 Changed 5 years ago by mcs

Status: newneeds_information

So you never see any application windows, correct?

Did you install Tor Browser 4.0 into a new folder? If not, please do so and see if it starts correctly.

If the problem persists even after installing into a new folder, please follow these steps to capture some logging information:

1) Use a text editor to modify the file Tor Browser\Browser\TorBrowser\Data\Browser\profile.default\prefs.js and add these four lines:

user_pref("extensions.torbutton.loglevel", 0);
user_pref("extensions.torbutton.logmethod", 0);
user_pref("extensions.torlauncher.loglevel", 0);
user_pref("extensions.torlauncher.logmethod", 0);

Save the changes.

2) Start a Command Prompt (cmd.exe) and cd to Tor Browser\Browser (the folder that contains firefox.exe).

3) At the command prompt, type: firefox -console -jsconsole
A new console window should be opened. Copy all of the log lines that are recorded there and paste them into this ticket.

Thanks!

comment:6 in reply to:  5 ; Changed 5 years ago by Hoo170

Correct no application windows are visible.

I originally installed over the previous version but after it failed I read a blog that indicated to install it in a new folder and also one that was not on the desktop I tried both of these with still no luck. I tried to locate the file you asked me to modify but it does not exist in the directory you suggest.

in the directory C:\Users\Steve\Desktop\v4.0\Tor Browser\Browser\TorBrowser\Data\Browser\profile.default are the following files

extensions (folder)
preferences (folder)
bookmarks.html
compatibility.ini
parent.lock

Regards,

Steve.

comment:7 in reply to:  6 Changed 5 years ago by mcs

Replying to Hoo170:

in the directory C:\Users\Steve\Desktop\v4.0\Tor Browser\Browser\TorBrowser\Data\Browser\profile.default are the following files

extensions (folder)
preferences (folder)
bookmarks.html
compatibility.ini
parent.lock

Is this true after you try to start the browser? (the prefs.js file will be created during browser startup if things progress far enough). If the file does not exist, you can create it next to bookmarks.html and the other files. Just make sure it is a plain text file that contains the user_pref() lines I provided earlier.

After you create or modify prefs.js, please perform the Command Prompt experiment I described earlier.

Is there any chance that anti-virus or anti-malware software is preventing Tor Browser from starting?

comment:8 Changed 5 years ago by Hoo170

I have managed to get a version of 3.5.5 from a friend and that works fine. It seems to be just v4 that does not work. I would expect by Norton anti-virus would affect both in the same way.

I will try creating the perfs.js file as you suggest and post the results.

Steve.

comment:9 Changed 5 years ago by Hoo170

Ok so I created a file in the directory as directed above with the lines supplied.

I opened a command window and change directory to the Browser folder that contains firefox

I entered firefox -console -jsconsole

A new window opened and an error box saying Tor has stopped working, looking for solution. No other information was displayed.

Steve.

comment:10 in reply to:  9 Changed 5 years ago by mcs

Replying to Hoo170:

A new window opened and an error box saying Tor has stopped working, looking for solution. No other information was displayed.

OK. It sounds like Tor Browser is crashing pretty early. Does that error box (displayed by Windows) include a "View problem details" button near the bottom? If so, please click it and paste the problem details into this ticket.

There are now a couple of other "crash during startup" reports that have been filed, so your problem may be a duplicate of one of them: #13547, #13492.

comment:11 Changed 5 years ago by cypherpunks

There are now a couple of other "crash during startup" reports that have been filed, so your problem may be a duplicate of one of them: #13547, #13492.

and #13549 (with screenshot), or similar report.

Firefox does start but shuts down shortly after.

Any security related software used like Trusteer End Point Protection (Rapport)?

comment:12 Changed 5 years ago by Hoo170

Hi there was not a view problem details option so could not include any details. I did notice that when it crashes it starts something called WerFault.exe running for a few seconds.

I do have Rapport running but as I have said version 3.6.6 was running and I now have version 3.5 running, I could not find a copy of 3.6.6 anywhere.

It looks to me like the install is not complete as looking at the directories under 3.5 there are a lot more files there.

Steve.

comment:13 Changed 5 years ago by Hoo170

Hi I have started event viewer and can see the crash for firefox and it is the same as that supplied under ticket #13547.

Steve.

comment:14 Changed 5 years ago by cypherpunks

I do have Rapport running but as I have said version 3.6.6 was running and I now have version 3.5 running, I could not find a copy of 3.6.6 anywhere.

It's Rapport Software problem, it needs update to learn about new Tor Browser version, like it happened before. See #8337

comment:15 in reply to:  13 Changed 5 years ago by mcs

Resolution: duplicate
Status: needs_informationclosed

Replying to Hoo170:

Hi I have started event viewer and can see the crash for firefox and it is the same as that supplied under ticket #13547.

Thanks for your persistence in debugging this problem (and thanks to cypherpunks for his/her contributions). I am resolving this ticket as a duplicate of #13547; please follow up there.

It looks to me like the install is not complete as looking at the directories under 3.5 there are a lot more files there.

We changed the directory structure in Tor Browser 4.0; that probably explains the missing files.

Note: See TracTickets for help on using tickets.