Opened 5 years ago

Closed 20 months ago

#13485 closed defect (duplicate)

Torbutton icon is squashed and ugly in TBB 4.0

Reported by: arma Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In the new Tor Browser 4.0, the new Firefox chrome has changed the sizes and so on of the icons.

Our little green onion appears to have the bottom and top cut off of it, and also it's been shrunk.

What are some good fixes?

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by mcs

Search for Icon sizes in toolbars have changed on this page:

https://developer.mozilla.org/en-US/Firefox/Australis_add-on_compat

Torbutton includes a 16x16 pixel icon (tor-16.png) so I think we just need to revise our CSS so it gets used on the toolbar. And we should add CSS rules so that our 32x32 pixel icon (tor.png) is used in the Menu Panel and Customization areas.

comment:2 Changed 5 years ago by arma

Sounds great!

comment:3 Changed 5 years ago by mcs

Status: newneeds_information

Kathy Brade and I tried to create a patch for this (just some CSS changes, right?). What is really going on is that images like tor-enabled-16.png (https://gitweb.torproject.org/user/brade/torbutton.git/blob_plain/HEAD:/src/chrome/skin/tor-enabled-16.png) are being used in TB 4.0, but there are a couple of factors that make them look bad:

  1. On Linux, previously we used 24 x 24 pixel icons. With Firefox's Australis redesign, only the small icons are used (typically 16 x 16 pixels).
  1. Our small icons are not really 16x16 pixels, and in fact they are cropped so as to not cause problems. See #8941.

What we really need are some high-quality 16x16 pixel icons. Does anyone know who created the toolbar icons we use in Torbutton today? I could not find them on https://media.torproject.org/ but maybe I missed them. We could just start over (extract the onion from https://media.torproject.org/image/official-images/2011-tor-logo-flat.svg, export as PNG, colorize, add the red 'X' to the -disabled icons, etc.)

comment:4 Changed 23 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:5 Changed 20 months ago by gk

Resolution: duplicate
Status: needs_informationclosed

Making this a duplicate of #25410 which should get resolved when we are doing our UI redesign.

Note: See TracTickets for help on using tickets.