Opened 5 years ago

Closed 5 years ago

#13492 closed defect (duplicate)

Tor Browse 4.0 crashing (kernel32.dll) on Windows

Reported by: Sherief Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: mcs, brade, gk, mikeperry, lunar, phoul Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Several users emailed the help desk that Tor Browser crashes for them on Windows (so far XP, Vista and 7).

Crash logs:

Problem Event Name: APPCRASH
Application Name: firefox.exe
Application Version: 31.2.0.0
Application Timestamp: 00000000
Fault Module Name: kernel32.dll
Fault Module Version: 6.0.6002.19034
Fault Module Timestamp: 52f2ec86
Exception Code: c06d007f
Exception Offset: 0003fd1e
OS Version: 6.0.6002.2.2.0.256.1
Locale ID: 1033
Additional Information 1: b21f
Additional Information 2: 6e4711530702c06e1b1cc962f59f2d86
Additional Information 3: 98d2
Additional Information 4: f9ae74c4676376c58e55ffecdfcbaa6c
Faulting application name: firefox.exe, version: 31.2.0.0, time stamp:
0x00000000
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp:
0x53159a86
Exception code: 0xc06d007f
Fault offset: 0x0000c42d
Faulting process id: 0x1194
Faulting application start time: 0x01cfeaea1fbdd396
Faulting application path: C:\Users\X\Tor Browser\Browser\firefox.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 5e7a0d59-56dd-11e4-b780-4061862e4569

This is what shows in Window error reporting:
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: firefox.exe
P2: 31.2.0.0
P3: 00000000
P4: KERNELBASE.dll
P5: 6.1.7601.18409
P6: 53159a86
P7: c06d007f
P8: 0000c42d
P9:
P10:

Child Tickets

Change History (9)

comment:1 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #13443.

comment:2 Changed 5 years ago by cypherpunks

Summary: Tor Browse 4.0 crashing on WindowsTor Browse 4.0 crashing (kernel32.dll) on Windows

It is not duplicate of #13443. Different:

Fault Module Name: kernel32.dll
Exception Code: c06d007f
Exception Offset: 0003fd1e

It's different crash, see #13547 for yet one.

comment:3 in reply to:  2 ; Changed 5 years ago by gk

Replying to cypherpunks:

It is not duplicate of #13443. Different:

Good point. I wonder whether Antivirus/Firewall software is involved here?

comment:4 Changed 5 years ago by gk

Resolution: duplicate
Status: closedreopened

comment:5 in reply to:  3 Changed 5 years ago by Sherief

Replying to gk:

Replying to cypherpunks:

It is not duplicate of #13443. Different:

Good point. I wonder whether Antivirus/Firewall software is involved here?

I thought this was related to #13443 but now I am sure it's different. The symptom is that Tor Browser 4 crashes right after start tor browser is launched.

This is not as frequent as #13443 and #13472 but it's there. Let me know if there is any information you need from the help desk side.

comment:6 Changed 5 years ago by cypherpunks

I wonder whether Antivirus/Firewall software is involved here?

Or system files corrupted.

Let me know if there is any information you need from the help desk side.

Could you to ask affected users to verify system files, using step 3 of manual (for win7):
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html (sfc /verifyonly)

comment:7 Changed 5 years ago by cypherpunks

I wonder whether Antivirus/Firewall software is involved here?

#13547 and this bug is about Trustee Rapport probably. User in comments mentioned crash at KERNELBASE.dll fault module if Trusteer service running.

comment:8 in reply to:  7 Changed 5 years ago by Sherief

Replying to cypherpunks:

I wonder whether Antivirus/Firewall software is involved here?

#13547 and this bug is about Trustee Rapport probably. User in comments mentioned crash at KERNELBASE.dll fault module if Trusteer service running.

Confirmed by a couple of users through the help desk.

comment:9 Changed 5 years ago by cypherpunks

Resolution: duplicate
Status: reopenedclosed

Duplicate of #8337.

Note: See TracTickets for help on using tickets.