Opened 5 years ago

Closed 3 years ago

#13503 closed defect (duplicate)

Tor Browser does nothing when clicking "Allow" for offline storage use

Reported by: isis Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-pref, tbb-usability
Cc: isis, mikeperry, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by isis)

I wanted to checkout a "secure webmail app" that a friend was talking about. When navigating to https://mail.whiteout.io/ in Tor Browser 4.0, however, I cannot click the "Allow" button.

https://trac.torproject.org/projects/tor/raw-attachment/ticket/13503/mail.whiteout.io.offline-allow.jpg

FWIW, the Preferences > Advanced > Offline Web Content and User Data > Tell me when a website asks to store data for offline use checkbox is checked. However that setting only toggles the browser.offline-apps.notify pref. I think what we want is browser.cache.offline.enable=true, but we'd likely need to audit those APIs to ensure they do not do anything potentially unsafe.

Child Tickets

Attachments (1)

mail.whiteout.io.offline-allow.jpg (32.1 KB) - added by isis 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by isis

comment:1 Changed 5 years ago by isis

Description: modified (diff)

comment:2 Changed 5 years ago by isis

Description: modified (diff)

comment:3 Changed 5 years ago by gk

How do I get so far at all taking a vanilla Tor Browser 4.0? Even with leaving Private Browsing Mode and allowing to save things to disc (which should solve your problem) I am just seeing a throbber on https://mail.whitehout.io/#/login.

comment:4 Changed 3 years ago by cypherpunks

Resolution: duplicate
Severity: Normal
Status: newclosed

Closed as a duplicate of #6474.

Note: See TracTickets for help on using tickets.