Opened 5 years ago

Closed 5 years ago

#13505 closed defect (not a bug)

TBB 4 requires GLIBC version unavailable in Debian Wheezy

Reported by: tbuser Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Debian Wheezy stable (newly apt-get updated and upgraded today) while trying to start FF in TBB 4 I get

/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /root/tor-browser_en-US/Browser/libxul.so)
Couldn't load XPCOM.

Wheezy uses GCC 4.7 with libstdc++ 6.0.17, but TBB 4 depends on GLIBCXX_3.4.20 which is in libstdc++ 6.0.20 with GCC 4.9, which aren't available in Wheezy. Did I miss something, or does TBB 4 not run on Wheezy?

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by arma

Works fine on my wheezy.

Did you get the 32-bit vs 64-bit choice correct?

comment:2 Changed 5 years ago by arma

(Also, why do you run Tor Browser as root? Bad idea usually.)

comment:3 Changed 5 years ago by boklm

How do you start it ?

If you are using the start-tor-browser script, it should set LD_LIBRARY_PATH to the directory Browser/TorBrowser/Tor which contains a libstdc++.so.6.

comment:4 Changed 5 years ago by tbuser

Resolution: not a bug
Status: newclosed

32 bit choice is correct. Running as root is ok because the VM that it's running in is used for nothing else.

I'm starting FF directly, not via the start-tor-browser script, because I need to avoid starting Tor (I'm using a separate VM to torrify the entire VM that FF runs in, and I'm using FF from TBB just to have the standard hardened FF that the TBB team produces). I didn't notice that TBB contains the libstdc++.so.6 that's needed. With LD_LIBRARY_PATH set, FF starts properly.

Thanks for the quick response, and sorry for the mistaken bug report. Closing as user error.

Note: See TracTickets for help on using tickets.