Opened 5 years ago

Closed 2 years ago

#13507 closed defect (worksforme)

webgl not working on new version of tor browser for windows

Reported by: keith768 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, ff52-esr-will-have
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems that webgl is not actually working in the new version (4.0) of tor browser (as it says in the patch notes..."Bug 10715: Enable WebGL on Windows (still click-to-play via NoScript) ")

The libEGL dlls are indeed included in the directory of the browser, and when the getContext('webgl') method (of canvas element) is called, those dlls are indeed loaded in the process, yet the method returns null. (Obviously I've enabled webgl through NoScript...)

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by gk

Keywords: tbb-usability added; webgl removed
Version: Tor: 0.2.4.25

comment:2 Changed 5 years ago by mcs

I am not an expert on WebGL, but I know it will only be enabled for certain graphics cards and drivers.

Does WebGL work on your system within Firefox 31 ESR?
What is shown in the Graphics section on the about:support page within Tor Browser?

comment:3 Changed 5 years ago by keith768

It does work on Firefox 31 ESR. I've also reproduced the problem on different windows versions (7, 8, 8.1...) and different hardware. So it's safe to assume it's not OS or hardware related.

Under the "Graphics" section it indeed shows different information between Tor Browser and regular firefox:

  1. DirectWrite is false in Tor Browser
  2. "GPU Accelerated Windows" is "1/1 Direct3D 10" on FF and "0/1 Basic" on Tor browser.
  3. AzureCanvasBackend is skia on Tor Browser, direct2d on FF.
  4. AzureContentBackend is cairo on Tor Browser, direct2d on FF
  5. Most important of all, the line of "WebGL Renderer" is completely missing on Tor Browser.

The rest of the section is identical (driver versions and all).

comment:4 in reply to:  3 Changed 3 years ago by bugzilla

Severity: Normal

Replying to keith768:

  1. Most important of all, the line of "WebGL Renderer" is completely missing on Tor Browser.

Not everywhere. Found on Win7 with integrated Intel graphics. about:support shows:

(#0) Assert	Potential driver version mismatch ignored due to missing DLLs

comment:5 Changed 2 years ago by cypherpunks

Keywords: ff52-esr-will-have added
Resolution: worksforme
Status: newclosed

Reopen if not.

Note: See TracTickets for help on using tickets.