Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13546 closed defect (not a bug)

update check while updates are disabled

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

the latest torbrowser release 4.0 logged this:
addons.update-checker WARN HTTP Request failed for an unknown reason
But, any type of update is disabled.

environment:
Plain vanilla english tor browser bundle 4.0

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed

No, extension updates are not disabled in a vanilla Tor Browser. And as we don't want to get updates for Torbutton and Tor Launcher via the built-in extensions update mechanism we point the update URLs to https://127.0.0.1. But that is failing due to #10419. So, this is no defect currently but intentionally implemented that way.

comment:2 Changed 5 years ago by cypherpunks

ok, i understand.
thanks, for the quick reply!

Note: See TracTickets for help on using tickets.