Opened 5 years ago

Closed 4 years ago

#13550 closed defect (duplicate)

'TypeError: counterItem is null' if no HTTPS-Everywhere button is in the toolbar

Reported by: gk Owned by: zyan
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get the exception mentioned in the summary when starting Tor Browser 4 (which does not have the HTTPS-Everyhwere toolbar button on the toolbar anymore). The offending line in question is:

    counterItem.setAttribute('checked', showCounter ? 'true' : 'false');

Should be a matter of a try-catch that is missing here I guess as HTTPS-Everywhere is still working as expected.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by gk

Summary: 'TypeError: counterItem is null' if no HTTPS-Everyhwere button is in the toolbar'TypeError: counterItem is null' if no HTTPS-Everywhere button is in the toolbar

comment:2 Changed 4 years ago by mcs

Cc: brade mcs added

This could be considered a duplicate of #12218 (the patch I just posted there fixes this bug).

comment:3 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #12218.

Note: See TracTickets for help on using tickets.