Opened 5 years ago

Closed 5 years ago

#13578 closed enhancement (duplicate)

Store Pluggable Transport information in database

Reported by: sysrqb Owned by: isis
Priority: Immediate Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords:
Cc: isis, sysrqb Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We currently save a bridge's ip address, orport, first seen timestamp, last seen timestamp, and distributor assignment in the database. Until now we've only needed this information, all other information is stored in-memory during runtime. With #13570 we need the bridge's PT information, as well.

Unfortunately the current schema is not ideal for this, and it will very likely change with a migration to a different database backend. As such the easiest solution right now is to mirror the current class relation of PluggableTranport -> Bridge by creating a table with columns: addr, port, transport, fingerprint (?). #9652 would help simply this relationship, in the future.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by sysrqb

To be clear, I want this information in the database because I don't want to parse the descriptors again for #13570 or any subsequent task. BridgeDB already does this for us, so caching it is easy. This can help with stability measurements and metrics in the future, as well.

comment:2 Changed 5 years ago by isis

Cc: isis sysrqb added
Resolution: duplicate
Status: newclosed

This is part of #12031, and in my branches for #12031 it's already coded for the new database system. #12031 is blocking on #9380, by the way. Whatever additional info that we need from descriptors or need stored in the new database should go on one or both of those tickets.

I think this is a duplicate of #12031, but if I've misunderstood something, please reopen.

Note: See TracTickets for help on using tickets.