Opened 5 years ago

Closed 4 years ago

#13579 closed defect (fixed)

TorBrowser 4.0: Download progress no longer updated automatically

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability AffectsTails, TorBrowserTeam201509R
Cc: lunar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Used software: TorBrowser 4.0 and Tails 1.2

Problem: The download progress is no longer updated automatically.

Details: If you download a file, you can switch to the download page in the menu to see the download speed, the remaining time and the already downloaded megabyte. Unfortunately, you have to reload the download page manually to see the current progress status. I think, that shouldn't be the normal behavior.

Child Tickets

Change History (10)

comment:1 Changed 5 years ago by anonym

Tracked in Tails as bug #8159.

A strange workaround is the following:

  1. Click on the all-in-one menu button and then Customize (as in "customize the GUI")
  2. Drag the Downloads button to somewhere on the navigation toolbar
  3. Restart the browser (once I didn't have to do this for some reason)
  4. Now the Downloads page updates automatically again

comment:2 Changed 5 years ago by mcs

I was able to reproduce this problem in Firefox 33.0.2 on Mac OS by removing the Downloads button from the Firefox toolbar. We should try to reproduce this problem in an ESR 31 Firefox and search for and/or file a Mozilla bug.

comment:3 Changed 5 years ago by gk

Cc: lunar added
Keywords: tbb-usability added

#14377 is a duplicate of this bug.

comment:4 Changed 5 years ago by cypherpunks

Keywords: AffectTails added

comment:5 Changed 5 years ago by cypherpunks

Keywords: AffectsTails added; AffectTails removed

comment:6 Changed 5 years ago by anonym

So this still affects the Tor Browser (both 4.0.8 and 4.5a5) even outside of Tails, it's just that it only affects during the first run, i.e. with a fresh profile. The reason it's more apparent in Tails is of course that each Tails boot will have a "first run" of the Tor Browser.

Two more things I've noticed:

  • The expected animation of a download arrow that disappears into the all-in-one button when starting a download doesn't show up when this bug is in effect, i.e. during the first run.
  • Even during the first run you can get a working (updating) download manager tab by going through the menu, Tools -> Downloads, or pressing Ctrl+Shift+Y.

So, it seems there's some problem with animations in the all-in-one menu during the first run with a fresh profile, that is inherited by the download manager tab if opened through it.

comment:7 Changed 4 years ago by anonym

Status: newneeds_review

Setting pref("browser.download.panel.shown", true); before starting the Tor Browser the first time will fix this issue.

comment:8 Changed 4 years ago by gk

Keywords: TorBrowserTeam201509R added

comment:9 Changed 4 years ago by gk

I've filed https://bugzilla.mozilla.org/show_bug.cgi?id=1203093 on Mozilla's side. Thanks for investigating this and proposing a fix. Looks good to me. I'll push it to our tor-browser branches.

comment:10 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Landed on tor-browser-38.2.1esr-5.5-2 and tor-browser-38.2.1esr-5.0-2 (commit 2e79f3111bc999b6f30f3ec43d47913a3f0e5002 and dd27a46185405a87cf5a8a56e4d293bddedde52a).

Note: See TracTickets for help on using tickets.